Bug 1023736 - JAR file should put into /usr/share/java/jline2/jline2.jar
JAR file should put into /usr/share/java/jline2/jline2.jar
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: jline2 (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Marek Goldmann
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-27 10:12 EDT by Jochen Schmitt
Modified: 2013-10-29 12:20 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-28 04:51:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Suggestion patch to solve the reported issue (2.15 KB, patch)
2013-10-27 10:12 EDT, Jochen Schmitt
no flags Details | Diff

  None (edit)
Description Jochen Schmitt 2013-10-27 10:12:35 EDT
Created attachment 816519 [details]
Suggestion patch to solve the reported issue

ON Rawhide the JAR file should be in

/usr/share/java/line2/jline2.ar

regrarding to the current Java packaging guidelines.

This is important, because the scala package create a symbolic link
to this JAR file.

Because there is a non-responsive package maintainer process agains the primary maintainer of this package, I plan to apply the suggestion patch as a provenpackager and start an addtional non-responsive maintainer process for this package too.
Comment 1 Jochen Schmitt 2013-10-27 10:15:43 EDT
Please forgett the last sentence about the non-responsive maintainership because I was accitendly in mind that jline2 has the same maintainer as the scala package.
Comment 2 Marek Goldmann 2013-10-28 04:51:28 EDT
Hi Jochen,

Currently we're in the process of renaming the jline* packages. jline will be renamed to jline1 and jline2 will be renamed to jline. Please see bug 1022897 for more info. After this the resulting package path will be following:

/usr/share/java/line/jline.jar

Having this in mind, I'm rejecting this bug report.

P.S. You shouldn't use manual symlinking *ever* in a spec file. There are tools for it like %mvn_install, %mvn_build, and %mvn_package macros, so I would reject your patch too.
Comment 3 Severin Gehwolf 2013-10-29 12:20:32 EDT
(In reply to Marek Goldmann from comment #2)
> Hi Jochen,
> 
> Currently we're in the process of renaming the jline* packages. jline will
> be renamed to jline1 and jline2 will be renamed to jline. Please see bug
> 1022897 for more info. After this the resulting package path will be
> following:
> 
> /usr/share/java/line/jline.jar

Small correction. It will be:
/usr/share/java/jline/jline.jar

However, I suggest to specify dependency on jline 2.x as follows (no need to know the precise file path):

Requires: mvn(jline:jline) >= 2.10

Note You need to log in before you can comment on or make changes to this bug.