Bug 102503 - PHP Warning: Unknown(): Unable to load dynamic library '/usr/lib/php4/pgsql.so'
Summary: PHP Warning: Unknown(): Unable to load dynamic library '/usr/lib/php4/pgsql.so'
Status: CLOSED DUPLICATE of bug 103690
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: php   
(Show other bugs)
Version: 1.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Joe Orton
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: CambridgeBlocker
TreeView+ depends on / blocked
 
Reported: 2003-08-16 00:29 UTC by angus
Modified: 2007-04-18 16:56 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-21 08:29:14 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description angus 2003-08-16 00:29:11 UTC
Description of problem:
/usr/lib/php4/pgsql.so: undefined symbol: OnUpdateBool in Unknown on line 0

same problem when rebuild from src.rpm

Version-Release number of selected component (if applicable):
php-4.3.2-7 httpd-2.0.47-4

How reproducible:
Always

Steps to Reproduce:
1.service httpd start
2.less /var/log/httpd/error.log
3.try phpPgAdmin, unable to access postgresql database

Comment 1 angus 2003-08-16 00:32:35 UTC
Seems to be reported on buzilla of php.net but related to a patch applyied in
src.rpm, not in standart php tarball

http://bugs.php.net/bug.php?id=24853&edit=1

Comment 2 Joe Orton 2003-09-07 22:14:03 UTC
Thanks for the report; this bug was caused by the use of the
"--enable-versioning" switch to configure - the switch only worked because of a
bug in libtool 1.4 and earlier.  When php was built with --enable-versioning and
libtool 1.5, --enable-versioning breaks horribly.

*** This bug has been marked as a duplicate of 103690 ***

Comment 3 angus 2003-09-10 11:51:53 UTC
Fine but where is php-4.3.3-2 available ?
because rawhide has not been update since Sept 7


Note You need to log in before you can comment on or make changes to this bug.