Bug 102530 - upgrading to gnome-panel-2.3.6.2-2.i386 from rawhide "kills" default
upgrading to gnome-panel-2.3.6.2-2.i386 from rawhide "kills" default
Status: CLOSED RAWHIDE
Product: Red Hat Linux Beta
Classification: Retired
Component: gnome-panel (Show other bugs)
beta1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Havoc Pennington
:
: 103542 (view as bug list)
Depends On:
Blocks: CambridgeBlocker
  Show dependency treegraph
 
Reported: 2003-08-16 15:10 EDT by Elton Woo
Modified: 2007-04-18 12:56 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-09-10 09:07:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
error messages when updating to this package version (945 bytes, text/plain)
2003-08-16 15:12 EDT, Elton Woo
no flags Details
The gnome desktop after latest rawhide updates (02 Sep. 2003) (558.31 KB, image/png)
2003-09-03 12:41 EDT, Elton Woo
no flags Details
detailed view of the gnome panel, showing "cramped" tasks at far right. (30.29 KB, image/png)
2003-09-03 12:42 EDT, Elton Woo
no flags Details

  None (edit)
Description Elton Woo 2003-08-16 15:10:12 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030703

Description of problem:
upgrading to panel-2.3.6.2-2.i386, deletes the default
floating panel from the bottom of the Gnome desktop.

Version-Release number of selected component (if applicable):
 gnome-panel-2.3.6.2-2.i386

How reproducible:
Always

Steps to Reproduce:
1. download and install (UPGRADE) gnome-panel-2.3.6.2-2.i386 from rawhide
2. logout of the desktop
3. login to gnome desktop again.
    

Actual Results:  the default floating panel is no longer present, and one can only
exit the desktop by CTRL-ALT-BKSPC

Expected Results:  the floating panel shold be present on and at the bottom of
the desktop

Additional info:

If one removes (rpm -nodeps) the panel, and reverts to the
gnome-panel-2.2.0.1-9.i386.rpm from Severn, instead of the default
floater at the bottom of the screen, there is a gnome panel at
the top of the screen *without* the slider buttons.
Comment 1 Elton Woo 2003-08-16 15:12:31 EDT
Created attachment 93685 [details]
error messages when updating to this package version
Comment 2 Alexander Larsson 2003-08-18 05:07:43 EDT
your machine is named knoppix? :)
Comment 3 Elton Woo 2003-08-18 14:26:29 EDT
I tried the Knoppix CD, and it overwrote my dhcp client info. (I don't know where
to look to correct this). <*shrug*>. I've now recreated the default floating
panel, but now I have also the top-of-screen menu bar.
Comment 4 Mike Chambers 2003-08-19 23:46:02 EDT
I too upgraded and no panel once you log back in.  gnome-panel-2.3.6.2-3
Comment 5 Alexander Larsson 2003-08-20 04:26:33 EDT
Hmmm. I though gnome-panel-2.3.6.2-3 should fix this issue. It didn't?
Comment 6 Mike Chambers 2003-08-20 06:56:06 EDT
Nope.  Even created and logged in with new user and doesnt' work for it either.
 Maybe there is something that didn't get updated that is causing it?  I pretty
much just upgraded most packages in rawhide that had gnome-2.3, and didn't do
any other packages, such as bonobo or any lib packages or anything.
Comment 7 Chris Ricker 2003-08-20 10:00:03 EDT
Try upgrading to today's rawhide and deleting all existing config files. That
fixed Bug #102559 for me, which was probably the same bug....
Comment 8 Elton Woo 2003-08-20 14:42:46 EDT
by deleting all config files, do you mean the following hidden directories? --->
.gconf, .gconfd, .gnome, .gnome2, .gnome2_private, and .gnome desktop  ...?
I am now running Gnome, with a "default" panel at the top of the screen, but the
Severn sliding panel at the _bottom_ of the screen is not there.
gnome-panel-2.3.6.2-3 * doesn't* fix the problem.

I removed the following: gnome-desktop, gnome-panel, gnome-utils, and
gnome-pilot, using rpm --nodeps, re-installing the original packages, from the
Severn CD's.
*Then* I upgraded to gnome-panel-2.3.6.2-3, gnome-applets-2.3.6.1. The latter is
missing an applet in the script, so now when I try to add the volume control to
the upper screen panel, I can't. (It "doesn't exist", in effect).
Comment 9 Mike Chambers 2003-08-20 18:39:49 EDT
This is the error I get when trying to install/upgrade the package...

[root@bart rawhide]# rpm -Uvh gnome-panel-2.3.6.2-3.i386.rpm
Preparing...                ########################################### [100%]
   1:gnome-panel            ########################################### [100%]
Error on option --load: unknown option.
Run 'gconftool-2 --help' to see a full list of available command line options.

And as stated before, even creating a new user, still don't get the panel.
Comment 10 Chris Ricker 2003-08-20 22:09:57 EDT
By all configs, I meant

rm -rf Desktop .gnome* .gtkrc-1.2-gnome2 .kde .nautilus .themes .thumbnails
.Trash .esd_auth .fonts.cache-1 .gconf* .ICEauthority .icons .rhn-applet.conf
Comment 11 Elton Woo 2003-08-22 12:48:55 EDT
Deleting the configuration files (hidden directories) as mentioned above,
*does* recreate the default Nautilus desktop (Home, StartHere, and Trash).
However, the gnome panel *consistently* segfaults and fails to load.
Comment 12 Alexander Larsson 2003-08-27 07:04:23 EDT
Ah, the "Error on option --load: unknown option." part is a hint.
It requires a recent version of GConf2. It should probably prereq 2.3.3.

Did everyone who got this see this warning? 
Does upgrading gconf2 and then forcing a panel upgrade again fix it?
Comment 13 Michael Young 2003-08-27 07:16:33 EDT
The above fix worked for me, though I had GConf2 as in rawhide yesterday already
installed.
Comment 14 Alexander Larsson 2003-08-27 09:06:12 EDT
If you installed the new gconf2 at the same time as the panel they could have
been installed in the wrong order, which is why the PreReq is needed.
Comment 15 Alexander Larsson 2003-08-27 09:17:26 EDT
I'm adding the PreReq to 2.3.7-1, can you please test if this fixes it?
Comment 16 Adam H. Pendleton 2003-08-28 08:47:28 EDT
I have gnome-panel-2.3.6.2-4 installed, and I'm seeing a different, but related,
problem.  When I install the beta, then run up2date and grab all the updates
from the beta-updates channel (including the above package), upon restarting my
system and logging back in, I see:

1) The main menu icon (RedHat logo) is gone, replaced with a folder.  The menu
contents are also different.  Using a hint from the mailing list archives, I
deleted this menu and added in the Main Menu.  This works, but now the icons in
the main menu are larger then they were before.

2) The desktop switcher, window list, notification area, and clock are all gone.
 I had to manually add all these back in (though I couldn't find the original clock)
Comment 17 Elton Woo 2003-09-03 12:40:03 EDT
I recently did a clean re-install of the system, and updated with the latest
packages from rawhide (02 Sep. 2003). The panel is now functioning, but it would
"lose" extra tasks to the far right of the screen, rather than resize the tasks
to fit. The only way to get to the tasks would be to use ALT-TAB and rotate 
through them. 

Kindly refer to attachment images: Full-Screenshot.pmg shows how it looks on
the desktop; CRAMPED_screen.png shows the detail at the far right.
Comment 18 Elton Woo 2003-09-03 12:41:52 EDT
Created attachment 94171 [details]
The gnome desktop after latest rawhide updates (02 Sep. 2003)

view of the complete desktop.
Comment 19 Elton Woo 2003-09-03 12:42:57 EDT
Created attachment 94172 [details]
detailed view of the gnome panel, showing "cramped" tasks at far right.
Comment 20 Elton Woo 2003-09-03 12:48:59 EDT
I thought I had "solved" this problem by moving the workspace switcher to the 
right of the screen, and them moving it back to the left of the tasks lists.
While it now managed to restore the normal behavoir of tasks, I can no longer
select anything from the main menu (red hat icon). The panel *consistently*
crashes with a segmentation fault.

Error message: Application "gnome-panel" (process 5603) has crashed
due to a fatal error.
(Segmentation fault)

I attempted to work around this by adding *another* Main Menu item, but this
also segfaults. The other default icons on the panel can be selected without
causing any crashes (mozilla, Evolution, OO applications, etc).
Comment 21 Elton Woo 2003-09-03 12:54:18 EDT
current versions on system(03 SEP. 2003):
gnome-pilot-2.0.9-2
gdk-pixbuf-gnome-0.22.0-3.0
gnome-panel-2.3.7-1
gnome-audio-extra-1.4.0-6
gnome-terminal-2.3.2-1
libgnomecanvas-2.3.6-1
gnome-session-2.3.7-3
gnome-icon-theme-1.0.6-1
gnome-media-2.3.7-1
gnome-python2-canvas-1.99.16-1
gnome-vfs2-extras-0.99.10-3.1
gnome-python2-bonobo-1.99.16-1
gnome-python2-1.99.16-1
gnome-utils-2.3.4-2
libgnomeui-2.3.6-2
libgnome-2.3.7-2
libgnomeprintui-1.116.0-5
gnome-mime-data-2.3.1-1
gnome-desktop-2.3.7-1
gnome-vfs-1.0.5-15
libgnomeprint15-0.37-7.1
gnome-print-0.37-7.1
gnome-themes-2.3.3-1
openssh-askpass-gnome-3.6.1p2-4
gnome-audio-1.4.0-6
gnome-vfs2-2.3.8-1
gnome-games-2.3.8-1
gnome-python2-gtkhtml2-1.99.16-1
gnome-vfs-extras-0.2.0-7
libgnomeprint22-2.3.1-2
libgnomeprintui22-2.3.1-1
gnome-libs-1.4.1.2.90-34
gnome-user-docs-2.0.1-3
gnome-applets-2.3.7-1
gnome-system-monitor-2.3.0-1
switchdesk-gnome-3.9.8-18
libgnomeprint-1.116.0-7
gnome-spell-1.0.5-2
up2date-gnome-3.9.20-2
Comment 22 Alexander Larsson 2003-09-04 08:04:53 EDT
Can you try gnome-panel 2.3.90-1?
Comment 23 Elton Woo 2003-09-04 12:16:30 EDT
With 2.3.7-1, I found that even adding another Main menu would put the panel
into a segfault loop. As a workaround. I created another user account, moved
my data there, then deleted my_account. Then after recreating my_account, I
moved the workspace-switcher over to the far right and loaded up several
different tasks. The result was that the task dialogs in the pamel resized
to fit (as they *should have*). I was able to move the workplace-switcher
to it's default location, and now my tasks do not push the panel clock or
other tasks off screen.

Nonetheless, I'll update to 2.3.90-1, as you suggest.
Comment 24 Alexandre Oliva 2003-09-04 17:55:32 EDT
*** Bug 103542 has been marked as a duplicate of this bug. ***
Comment 25 Elton Woo 2003-09-04 19:30:34 EDT
I've gone directly to redhat rawhide, but the latest verskion is 2.3.7-1,
not 2.3.90-1 (03 Sep.03)
Comment 26 Alexandre Oliva 2003-09-04 19:53:22 EDT
Since it was built today, it didn't make it to rawhide yet.  It's probably going
to be there tomrrow.
Comment 27 Alexander Larsson 2003-09-10 09:07:23 EDT
I belived this is working now. So i'm closing this bug. If there are problems
with 2.3.90-1 or later, please reopen with details about exactly what happened.

Note You need to log in before you can comment on or make changes to this bug.