Bug 1026468 - blivet shows existing LVs as not taking up any space in the VG
blivet shows existing LVs as not taking up any space in the VG
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: python-blivet (Show other bugs)
7.0
All Linux
unspecified Severity high
: beta
: ---
Assigned To: David Lehman
Release Test Team
:
Depends On: 1026466
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-04 12:49 EST by David Lehman
Modified: 2014-06-18 00:45 EDT (History)
6 users (show)

See Also:
Fixed In Version: python-blivet-0.18.11-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1026466
Environment:
Last Closed: 2014-06-13 08:01:18 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Lehman 2013-11-04 12:49:01 EST
+++ This bug was initially created as a clone of Bug #1026466 +++

Description of problem:
Existing LVM configurations detected by blivet show existing VGs as having their full capacity available in spite of any existing LVs. This is due to a regression introduced when fixing bug 1013800.

Version-Release number of selected component (if applicable):
python-blivet-0.23.3-1

How reproducible:
Always

Steps to Reproduce:
1. create an anaconda automatic partitioning layout (write it to disk)
2. reboot into the installer using the same disk(s)
3. in the custom storage spoke, create a new LV

Actual results:
A new LV will be added with up to the full size of the VG even though the VG is already full.

Expected results:
Creation of a new LV should fail due to the disk(s) and VG being full.

Additional info:

--- Additional comment from David Lehman on 2013-11-04 12:47:41 EST ---

I have a patch for this and have verified that it fixes this problem.
Comment 1 David Lehman 2013-11-13 10:39:01 EST
To be clear, this bug circumvents all checking done by the installer related to accounting for free space within a preexisting VG. That means, for example, that a user would be allowed to add a 100GB LV to an existing 200GB VG that has no free space.
Comment 3 Jan Stodola 2013-11-19 11:00:55 EST
Reproduced with python-blivet-0.18.9-1.el7, verified with python-blivet-0.18.11-1.el7
Comment 4 Ludek Smid 2014-06-13 08:01:18 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.