Bug 1027366 - bluedevil/kded crashes when other device attempts to pair
bluedevil/kded crashes when other device attempts to pair
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: bluedevil (Show other bugs)
20
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jaroslav Reznik
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:2debd36b2fe10af91d2ef76d37e...
: Reopened, Triaged, Upstream
: 1030590 1043544 1045653 1046001 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-06 11:35 EST by Jozef Mlich
Modified: 2015-08-02 19:58 EDT (History)
14 users (show)

See Also:
Fixed In Version: bluedevil-2.0.0-0.11.rc1.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-03 19:52:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (37.84 KB, text/plain)
2013-11-06 11:35 EST, Jozef Mlich
no flags Details
File: cgroup (160 bytes, text/plain)
2013-11-06 11:35 EST, Jozef Mlich
no flags Details
File: core_backtrace (5.94 KB, text/plain)
2013-11-06 11:35 EST, Jozef Mlich
no flags Details
File: dso_list (16.36 KB, text/plain)
2013-11-06 11:35 EST, Jozef Mlich
no flags Details
File: environ (3.08 KB, text/plain)
2013-11-06 11:35 EST, Jozef Mlich
no flags Details
File: limits (1.29 KB, text/plain)
2013-11-06 11:36 EST, Jozef Mlich
no flags Details
File: maps (82.82 KB, text/plain)
2013-11-06 11:36 EST, Jozef Mlich
no flags Details
File: open_fds (102 bytes, text/plain)
2013-11-06 11:36 EST, Jozef Mlich
no flags Details
File: proc_pid_status (947 bytes, text/plain)
2013-11-06 11:36 EST, Jozef Mlich
no flags Details
File: var_log_messages (207 bytes, text/plain)
2013-11-06 11:36 EST, Jozef Mlich
no flags Details
backtrace (17.84 KB, text/plain)
2013-12-11 21:52 EST, Dan Mossor [danofsatx]
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 327765 None None None Never

  None (edit)
Description Jozef Mlich 2013-11-06 11:35:22 EST
Version-Release number of selected component:
kdelibs-4.11.3-1.fc20

Additional info:
reporter:       libreport-2.1.9
backtrace_rating: 4
cmdline:        kded4
crash_function: KCrash::defaultCrashHandler
executable:     /usr/bin/kded4
kernel:         3.11.7-300.fc20.x86_64
runlevel:       N 5
type:           CCpp
uid:            21446

Truncated backtrace:
Thread no. 1 (10 frames)
 #1 KCrash::defaultCrashHandler at /usr/src/debug/kdelibs-4.11.3/kdeui/util/kcrash.cpp:346
 #3 findNode at /usr/include/QtCore/qmap.h:483
 #4 contains at /usr/include/QtCore/qmap.h:555
 #5 BlueDevil::Adapter::deviceForUBI at /usr/src/debug/libbluedevil-2.0/bluedevil/bluedeviladapter.cpp:190
 #6 BluezAgent::RequestConfirmation at /usr/src/debug/bluedevil-2.0.0/src/daemon/kded/bluezagent.cpp:128
 #7 BluezAgent::qt_static_metacall at /usr/src/debug/bluedevil-2.0.0/x86_64-redhat-linux-gnu/src/daemon/kded/moc_bluezagent.cpp:81
 #8 qt_static_metacall at /usr/src/debug/bluedevil-2.0.0/x86_64-redhat-linux-gnu/src/daemon/kded/moc_bluezagent.cpp:123
 #9 BluezAgent::qt_metacall at /usr/src/debug/bluedevil-2.0.0/x86_64-redhat-linux-gnu/src/daemon/kded/moc_bluezagent.cpp:124
 #10 QDBusConnectionPrivate::deliverCall at qdbusintegrator.cpp:951
 #11 QDBusConnectionPrivate::activateCall at qdbusintegrator.cpp:856
Comment 1 Jozef Mlich 2013-11-06 11:35:34 EST
Created attachment 820534 [details]
File: backtrace
Comment 2 Jozef Mlich 2013-11-06 11:35:39 EST
Created attachment 820535 [details]
File: cgroup
Comment 3 Jozef Mlich 2013-11-06 11:35:47 EST
Created attachment 820536 [details]
File: core_backtrace
Comment 4 Jozef Mlich 2013-11-06 11:35:52 EST
Created attachment 820537 [details]
File: dso_list
Comment 5 Jozef Mlich 2013-11-06 11:35:57 EST
Created attachment 820538 [details]
File: environ
Comment 6 Jozef Mlich 2013-11-06 11:36:02 EST
Created attachment 820539 [details]
File: limits
Comment 7 Jozef Mlich 2013-11-06 11:36:08 EST
Created attachment 820540 [details]
File: maps
Comment 8 Jozef Mlich 2013-11-06 11:36:13 EST
Created attachment 820541 [details]
File: open_fds
Comment 9 Jozef Mlich 2013-11-06 11:36:18 EST
Created attachment 820542 [details]
File: proc_pid_status
Comment 10 Jozef Mlich 2013-11-06 11:36:26 EST
Created attachment 820543 [details]
File: var_log_messages
Comment 11 Dan Mossor [danofsatx] 2013-12-11 21:51:22 EST
I'm hitting this one too after loading bluez-5.12-1.fc20.x86_64 to test the fix for bz 1027365.
Comment 12 Dan Mossor [danofsatx] 2013-12-11 21:52:36 EST
Created attachment 835557 [details]
backtrace
Comment 13 Rex Dieter 2013-12-19 10:03:09 EST
*** Bug 1030590 has been marked as a duplicate of this bug. ***
Comment 14 Rex Dieter 2013-12-19 10:03:23 EST
*** Bug 1043544 has been marked as a duplicate of this bug. ***
Comment 15 Kevin Kofler 2013-12-20 18:56:41 EST
*** Bug 1045653 has been marked as a duplicate of this bug. ***
Comment 16 Rex Dieter 2013-12-23 04:30:18 EST
*** Bug 1046001 has been marked as a duplicate of this bug. ***
Comment 17 Rex Dieter 2013-12-23 04:39:39 EST
This should be fixed by recent update,
https://admin.fedoraproject.org/updates/FEDORA-2013-23248/bluedevil-2.0.0-0.5.20131128.fc20,libbluedevil-2.0-0.2.20131113.fc20
(now in stable updates).
Comment 18 Kevin Kofler 2013-12-23 06:58:24 EST
Uh, no. This was fixed upstream on December 19, it can't be fixed in the November 12 snapshot. You need to queue the latest snapshot, which should fix all these crashes.
Comment 19 Fedora Update System 2013-12-23 07:03:47 EST
libbluedevil-2.0-0.4.20131220.fc20, bluedevil-2.0.0-0.8.20131219.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/FEDORA-2013-23719/libbluedevil-2.0-0.4.20131220.fc20,bluedevil-2.0.0-0.8.20131219.fc20
Comment 20 Fedora Update System 2013-12-24 21:37:19 EST
Package bluedevil-2.0.0-0.11.rc1.fc20, libbluedevil-2.0-0.6.rc1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing bluedevil-2.0.0-0.11.rc1.fc20 libbluedevil-2.0-0.6.rc1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-23719/bluedevil-2.0.0-0.11.rc1.fc20,libbluedevil-2.0-0.6.rc1.fc20
then log in and leave karma (feedback).
Comment 21 Fedora Update System 2013-12-27 21:10:34 EST
bluedevil-2.0.0-0.11.rc1.fc20, libbluedevil-2.0-0.6.rc1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 23 Kevin Kofler 2014-01-03 19:52:29 EST
Please keep this bug closed, I can assure you that THIS crash is fixed. The crash in bug #1048063 has a different backtrace according to the faf link. Please attach a backtrace with debugging information to that bug.

Note You need to log in before you can comment on or make changes to this bug.