Bug 1027455 - More recent puppet-pacemaker in packstack-modules-puppet
More recent puppet-pacemaker in packstack-modules-puppet
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-packstack (Show other bugs)
4.0
Unspecified Linux
high Severity medium
: rc
: 4.0
Assigned To: Martin Magr
Lon Hohberger
: OtherQA, Triaged
: 1031797 (view as bug list)
Depends On:
Blocks: 998597 1027456 1031797 1049121 1049122
  Show dependency treegraph
 
Reported: 2013-11-06 16:33 EST by Crag Wolfe
Modified: 2016-04-26 10:37 EDT (History)
7 users (show)

See Also:
Fixed In Version: openstack-packstack-2013.2.1-0.14.dev919.el6ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1027456 1031797 (view as bug list)
Environment:
Last Closed: 2013-12-19 19:34:19 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 60201 None None None Never

  None (edit)
Description Crag Wolfe 2013-11-06 16:33:14 EST
Description of problem:

And older version of the puppet-pacemaker module exists in the latest openstack-puppet-modules rpm.  It should instead be equivalent to https://github.com/radez/puppet-pacemaker/commit/0b16aea22c8a03ddadf42837bcf0990355f961ff .
Comment 2 Alvaro Lopez Ortega 2013-12-04 12:01:47 EST
Pacemaker isn't used in Packstack, so moving it to openstack-puppet-modules.
Comment 3 Alvaro Lopez Ortega 2013-12-04 12:23:48 EST
*** Bug 1031797 has been marked as a duplicate of this bug. ***
Comment 4 Jason Guiditta 2013-12-04 12:39:26 EST
But it _is_ used by foreman, so it is needed in packstack-modules-puppet.  We use that rpm for our puppet dependencies just like packstack does
Comment 5 Martin Magr 2013-12-05 06:07:28 EST
Moving bug to the correct component doesn't mean we won't add it to packstack submodule set, since it is source for openstack-puppet-modules.
Comment 7 Scott Lewis 2013-12-09 10:33:42 EST
Adding OtherQA for bugs in MODIFIED
Comment 10 Lon Hohberger 2013-12-11 15:02:02 EST
I verified that this matches expected:

[root@localhost ~]# rpm -ql openstack-packstack | grep pacemaker | grep filesystem
/usr/lib/python2.6/site-packages/packstack/puppet/modules/pacemaker/manifests/resource/filesystem.pp
[root@localhost ~]# cat /usr/lib/python2.6/site-packages/packstack/puppet/modules/pacemaker/manifests/resource/filesystem.pp
class pacemaker::resource::filesystem($device,
                                      $directory,
                                      $fstype,
                                      $group='',
                                      $interval="30s",
                                      $ensure=present) {
  $resource_id = delete("fs-${directory}", '/')
  pacemaker::resource::base { $resource_id:
    resource_type   => "Filesystem",
    resource_params => "device=${device} directory=${directory} fstype=${fstype}",
    group           => $group,
    interval        => "30s",
    ensure          => $ensure,
  }
}

openstack-packstack-2013.1.1-0.37.dev705.el6ost.noarch
Comment 12 errata-xmlrpc 2013-12-19 19:34:19 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1859.html

Note You need to log in before you can comment on or make changes to this bug.