Bug 998597 - Install a Highly Available OpenStack deployment using Foreman (haproxy)
Install a Highly Available OpenStack deployment using Foreman (haproxy)
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-foreman-installer (Show other bugs)
4.0
Unspecified Unspecified
high Severity high
: z1
: 4.0
Assigned To: Jason Guiditta
Omri Hochman
: FutureFeature, ZStream
: 1027535 (view as bug list)
Depends On: 1010305 1010306 1027455
Blocks: RHOS40RFE 998623 1010310 1049121 1049122
  Show dependency treegraph
 
Reported: 2013-08-19 10:49 EDT by Charles Crouch
Modified: 2016-04-26 11:39 EDT (History)
9 users (show)

See Also:
Fixed In Version: openstack-foreman-installer-0.0.20-1.el6ost
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
: 998623 1049121 1049122 (view as bug list)
Environment:
Last Closed: 2014-01-23 09:22:18 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:0046 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform 4 Bug Fix and Enhancement Advisory 2014-01-22 19:51:59 EST

  None (edit)
Description Charles Crouch 2013-08-19 10:49:26 EDT
The goal here is to use the Foreman which is part of RHOS to deploy the core OpenStack controller services (and their dependencies) such that they will be highly available. This includes the following tasks from https://home.corp.redhat.com/wiki/rdo-usability-sprint

-Use Foreman to deploy RDO with load balanced services and HAProxy/keepalived (creation of LB Host Group)	 	 
-Use Foreman to deploy RDO with highly available mysql using Pacemaker/Corosync	
-Use Foreman to deploy RDO with highly available qpid
Comment 2 Jason Guiditta 2013-09-20 14:46:49 EDT
Since this is 3 separate deliverables on the sprint, would it make more sense to list each of them in their own BZs?
Comment 3 Mike Orazi 2013-10-21 11:46:31 EDT
This describes the desired end-state.  

The sprints are a function of breaking it apart at a technical level so each individual piece can be completed and confirmed on a unit level.

NOTE:  There is still some debate on the qpid HA so for beta we will limit to the first two (lb + ha/mysql).
Comment 4 Jason Guiditta 2013-10-28 16:18:25 EDT
Load Balancer and HA/mysql are in this release
Comment 6 Ami Jeain 2013-11-28 07:55:16 EST
Jason,

can u plz provide more info on the implementation (i.e. gerrit link etc.)
Comment 7 Jason Guiditta 2013-12-02 12:18:20 EST
Ami, we have not been using gerrit for anything to date, but the 2 host groups (HA Mysql and Load Balancer) merely need to be applied to a couple of nodes - note load balancer is not yet itself HA.  Overview can be found starting  here: http://openstack.redhat.com/Deploying_RDO_Using_Foreman#Load_Balancer

Let me know if you have more specific questions I can assist with.
Comment 8 Perry Myers 2013-12-09 10:54:20 EST
*** Bug 1027535 has been marked as a duplicate of this bug. ***
Comment 10 Jason Guiditta 2013-12-17 15:03:23 EST
I dont see a need for a doc text here.  This is more of a Feature that can/will be documented in official documentation vs notes on the BZ.
Comment 12 Mike Orazi 2014-01-06 23:55:06 EST
Let's limit the scope on this one to explicitly test the LB via haproxy for services on the controller node.  We'll track qpid ha in 1049122 and the ha/mysql setup in 1049121
Comment 17 Omri Hochman 2014-01-19 10:48:14 EST
Verified with:  openstack-foreman-installer-1.0.3-1.el6ost.noarch (puddle 2014-01-16.1)

/var/log/messages:
Jan 19 17:37:09 cougar14 haproxy[3263]: Proxy ceilometer-api started.
Jan 19 17:37:09 cougar14 haproxy[3263]: Proxy cinder-api started.
Jan 19 17:37:09 cougar14 haproxy[3263]: Proxy glance-api started.
Jan 19 17:37:09 cougar14 haproxy[3263]: Proxy glance-registry started.
Jan 19 17:37:09 cougar14 haproxy[3263]: Proxy heat-api started.
Jan 19 17:37:09 cougar14 haproxy[3263]: Proxy horizon started.
Jan 19 17:37:09 cougar14 haproxy[3263]: Proxy keystone-admin started.
Jan 19 17:37:09 cougar14 haproxy[3263]: Proxy keystone-public started.
Jan 19 17:37:09 cougar14 haproxy[3263]: Proxy nova-compute started.
Jan 19 17:37:09 cougar14 haproxy[3263]: Proxy nova-ec2 started.
Jan 19 17:37:09 cougar14 haproxy[3263]: Proxy nova-metadata started.
Jan 19 17:37:09 cougar14 haproxy[3263]: Proxy stats started.
Jan 19 17:37:09 cougar14 haproxy[3263]: Proxy swift-proxy started.


[root@cougar14]# /etc/init.d/haproxy status
haproxy (pid  3264) is running...
Comment 19 Jason Guiditta 2014-01-22 11:12:15 EST
I still don't see a reason for doc text here, as I mentioned in Comment #10
Comment 21 Lon Hohberger 2014-02-04 12:19:43 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2014-0046.html

Note You need to log in before you can comment on or make changes to this bug.