Bug 102775 - ld fails while building transcode 0.6.9
ld fails while building transcode 0.6.9
Status: CLOSED DUPLICATE of bug 103180
Product: Red Hat Raw Hide
Classification: Retired
Component: binutils (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks: CambridgeTarget
  Show dependency treegraph
 
Reported: 2003-08-20 17:11 EDT by Piergiorgio Sartor
Modified: 2007-04-18 12:57 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:58:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Piergiorgio Sartor 2003-08-20 17:11:07 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:1.4) Gecko/20030703

Description of problem:
ld from binutils-2.14.90.0.5-5 fails with segfault while building
transcode 0.6.9 using "-s" compiler option.
The line is:

gcc -D_REENTRANT -funroll-loops -ffast-math -Wall
-DMOD_PATH=\"/usr/local/lib/transcode\" -s -O3 -fomit-frame-pointer
-D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64 -o tcextract
tcextract.o extract_ac3.o extract_mpeg2.o extract_pcm.o extract_yuv.o
extract_rgb.o extract_dv.o ioaux.o extract_mp3.o scan_dv.o aux_pes.o
extract_ogm.o  -L/usr/src/transcode-0.6.9/libac3 -lac3_tc
-L/usr/src/transcode-0.6.9/libmpeg2 -lmpeg2cvs -L/usr/src/transcode-0.6.9/libvo
-lvout -L/usr/src/transcode-0.6.9/avilib -lavi -L/usr/lib /usr/lib/libdv.so -lm
-lpthread -ldl /usr/lib/libglib.so -ldl -lm -logg -lm -lvorbis -lm -lm -lpthread
-ldl

The result is:

collect2: ld terminated with signal 11 [Segmentation fault]

If "-s" is removed, the operation ends properly.


Version-Release number of selected component (if applicable):
binutils-2.14.90.0.5-5

How reproducible:
Always

Steps to Reproduce:
1. Install transcode 0.6.9
2. export CFLAGS="-s"; export CXXFLAGS="-s"
3. ./configure
4. make

Actual Results:  ld will crash with segfault while trying to link some plugin.

Expected Results:  ld should link properly all the objects. I suppose.

Additional info:

Sometimes the problem is not present if some object file is
removed, but, of course, then there are unresolved symbols.
Comment 1 Jakub Jelinek 2003-08-25 08:23:53 EDT
Is that reproduceable?
Comment 2 Piergiorgio Sartor 2003-08-25 15:59:58 EDT
Well, it happens always to me, also with the latest gcc 3.3.1-2 from Rawhide...
If I remove "-s" everything is fine.
BTW it's more than one linking that fails, also the subsequent ones
show the same problem.
Comment 3 Jakub Jelinek 2003-09-08 05:24:40 EDT

*** This bug has been marked as a duplicate of 103180 ***
Comment 4 Red Hat Bugzilla 2006-02-21 13:58:10 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.