Bug 103180 - ld dumps core when linking optimized cryptcat
Summary: ld dumps core when linking optimized cryptcat
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux Beta
Classification: Retired
Component: binutils (Show other bugs)
(Show other bugs)
Version: beta1
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact:
URL:
Whiteboard:
Keywords:
: 102775 103885 (view as bug list)
Depends On:
Blocks: CambridgeTarget
TreeView+ depends on / blocked
 
Reported: 2003-08-27 12:41 UTC by Chris Ricker
Modified: 2007-04-18 16:57 UTC (History)
5 users (show)

Fixed In Version: 2.14.90.0.5-7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-09-08 08:05:42 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
cryptcat src rpm (90.63 KB, application/octet-stream)
2003-08-27 12:42 UTC, Chris Ricker
no flags Details

Description Chris Ricker 2003-08-27 12:41:16 UTC
See attached cryptcat SRPM

On RHL 9, it's fine to rpmbuild -ba 
On severn yum'ed to rawhide, I get the following when building it:

cc -O2 -g -pipe -march=i386 -mcpu=i686 -c twofish2.cc
cc -O2 -g -pipe -march=i386 -mcpu=i686 -s         -DLINUX  -o cryptcat netcat.c
farm9crypt.o twofish2.o -lstdc++
collect2: ld terminated with signal 11 [Segmentation fault], core dumped
make[1]: *** [cryptcat] Error 1

If I edit the spec file and change the line

make CFLAGS="$RPM_OPT_FLAGS" linux

to

make linux

then it compiles on rawhide, so it's only a problem when optimizing the code....

Comment 1 Chris Ricker 2003-08-27 12:42:11 UTC
Created attachment 93971 [details]
cryptcat src rpm

Comment 2 Chris Ricker 2003-08-27 16:22:59 UTC
Hmm, it's not an optimization issue after all, but the debugging info. The
problem is the -g that RPM_OPT_FLAGS adds.

cc -O2 -pipe -march=i386 -mcpu=i686 -s         -DLINUX  -o cryptcat netcat.c
farm9crypt.o twofish2.o -lstdc++

compiles just fine

cc -O2 -g -s -DLINUX -o cryptcat netcat.c farm9crypt.o twofish2.o -lstdc++

blows up when linking

this is

binutils-2.14.90.0.5-5
glibc-2.3.2-71
gcc-3.3.1-2

on an athlon

Comment 3 Chris Ricker 2003-08-27 16:33:00 UTC
Just yum'ed to today's rawhide

still true with glibc-2.3.2-78

Comment 4 Michael Lee Yohe 2003-08-28 16:17:21 UTC
I also get this whilst attempting to compile Rawhide man.

Comment 5 Michael Schwendt 2003-09-02 20:12:40 UTC
Same with svgalib from Fedora package request queue:

collect2: ld terminated with signal 11 [Segmentation fault]

* binutils-2.14.90.0.5-6 from Severn Updates (9.0.93-4)

The older binutils-2.14.90.0.4-19 from original Severn doesn't have that problem.

Comment 6 Jakub Jelinek 2003-09-08 08:03:43 UTC
*** Bug 103885 has been marked as a duplicate of this bug. ***

Comment 7 Jakub Jelinek 2003-09-08 08:05:42 UTC
Should be fixed in 2.14.90.0.5-7.

Comment 8 Jakub Jelinek 2003-09-08 09:24:50 UTC
*** Bug 102775 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.