Bug 1028110 - LVMError: lvresize failed for root: running lvm lvresize --force -L 8712m fedora/root failed
LVMError: lvresize failed for root: running lvm lvresize --force -L 8712m fed...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
https://fedoraproject.org/wiki/Common...
: CommonBugs
Depends On:
Blocks: F20FinalBlocker
  Show dependency treegraph
 
Reported: 2013-11-07 11:48 EST by Kamil Páral
Modified: 2013-11-26 05:15 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-26 05:15:06 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kamil Páral 2013-11-07 11:48:09 EST
Cloned from bug 1026466 comment 9:

Description of problem:
I tried to reproduce bug 1027682 or bug 1008732. I might have found yet another bug.

Reproducer:
1. Install a default Fedora LVM install - /boot as standard partition, swap and / as LVM.
2. Reboot into installer again.
3. Go into custom part and reuse /boot and swap.
4. Click on /, click Reformat and also resize it (I used 6 GB instead of original 8 GB). Click Apply.
5. See that the size was _not_ updated (that's probably related to bug 1027714).
6. Continue with install. See crash during installation start.

Please note that when I performed the same steps as above, but without the attempt to resize /, everything worked well.

cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:LABEL=Fedora\x2020-Beta\x20x86_64 quiet BOOT_IMAGE=vmlinuz 
hashmarkername: anaconda
kernel:         3.11.6-301.fc20.x86_64
package:        anaconda-20.25.6-1
product:        Fedora
reason:         LVMError: lvresize failed for root: running lvm lvresize --force -L 8712m fedora/root failed
release:        Cannot get release name.
version:        20-Beta

See anaconda-tb file as attachment 821098 [details].
Comment 1 Kamil Páral 2013-11-07 11:54:27 EST
This is probably a Final blocker:
"Any installer mechanism for resizing storage volumes must correctly attempt the requested operation. "
https://fedoraproject.org/wiki/Fedora_20_Final_Release_Criteria#Storage_volume_resize

I actually don't know whether the resize operation failed itself, or anaconda provided wrong arguments to it. However, crashing while attempting to resize LV is quite bad. (A thought: Because I wanted to reformat it anyway, could it be safer to just remove it and create anew with a different size?)
Comment 2 Adam Williamson 2013-11-13 12:58:29 EST
Discussed at 2013-11-13 blocker review meeting - http://meetbot.fedoraproject.org/fedora-blocker-review/2013-11-13/f20-final-blocker-review-1.2013-11-13-17.01.log.txt . Accepted as a blocker per criterion cited in c#1. According to program.log , anaconda for some reason tried to resize the volume to 8GB - the same as its existing size - and this causes lvresize to exit with a non-0 code. anaconda is clearly not correctly attempting 'the requested operation', as it didn't try to resize to 6GB.
Comment 3 Chris Murphy 2013-11-16 12:06:46 EST
While anaconda should not crash, I think it's a separate bug that lvresize doesn't exit with status 0 as it has "nothing to do". It's a null operation, so there can be no failure here.
Comment 4 Adam Williamson 2013-11-20 14:39:36 EST
Status reviewed at 2013-11-20 blocker review meeting: http://meetbot.fedoraproject.org/fedora-blocker-review/2013-11-20/f20-blocker-review.2013-11-20-17.00.log.txt . This bug seems to be clearly defined and reproducible and is now just waiting in the queue to be fixed by anaconda devs.
Comment 5 David Lehman 2013-11-21 10:31:54 EST
Please retest with 20-TC2 and report the results.
Comment 6 Kamil Páral 2013-11-25 05:03:47 EST
I verified that this is fixed in F20 TC2.
Comment 7 Kamil Páral 2013-11-26 05:15:06 EST
anaconda 20.25.9-1.fc20 is now stable, closing.

Note You need to log in before you can comment on or make changes to this bug.