Bug 1028929 - [RFE]Unified prefix for kernel arguments
[RFE]Unified prefix for kernel arguments
Status: CLOSED DUPLICATE of bug 1025252
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-node (Show other bugs)
unspecified
Unspecified Unspecified
high Severity high
: ---
: 3.6.0
Assigned To: Fabian Deutsch
Virtualization Bugs
node
: FutureFeature
Depends On: 1025252
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-11 04:20 EST by haiyang,dong
Modified: 2016-02-10 15:07 EST (History)
17 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: 1025252
Environment:
Last Closed: 2014-06-29 05:07:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Node
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description haiyang,dong 2013-11-11 04:20:45 EST
+++ This bug was initially created as a clone of Bug #1025252 +++

Description of problem:
Currently most kernel arguments used by Node are not having a prefix. To prevent collisions (e.g. bug 1020700) with other parts of the system Node's kernel arguments should be prefixed with a common prefix.

Some prefix ideas:
node.
nd.

node.example=foo
nd.example=foo
Comment 1 haiyang,dong 2013-11-11 04:25:24 EST
This feature is important for rhevh to prevent similarly  bug 1020700 to happen again, so need to clone it from upstream to track it in rhevh
Comment 3 RHEL Product and Program Management 2013-11-17 03:05:19 EST
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 5 Debi Rieden 2014-02-19 15:55:21 EST
Adding the lpc-rhel-7 flag, for change over to the simplified LPC process discussed in

http://openstack.etherpad.corp.redhat.com/lpc-update-proposal

Quick summary of simplifications to LPC:

[1] The lpc-rhel-7.0 flag will be replaced with lpc-rhel-7.  There will no longer be flags to indicate each release of RHEL7.  i.e. lpc-rhel-7.0, lpc-rhel-7.1, etc.

[2] Cloning bugs into LPC will no longer be necessary once the proposal is implemented.

[NOTE] Once the change is implemented, the lpc-rhel-7.0 flag will be disabled and you won’t see it on this bug, you will only see the lpc-rhel-7 flag.
Comment 6 Itamar Heim 2014-06-29 05:07:10 EDT
no need to track downstream until slated for a specific version if no customer ticket or specific partner tracking

*** This bug has been marked as a duplicate of bug 1025252 ***

Note You need to log in before you can comment on or make changes to this bug.