Bug 1029234 - RHEV message seen after upgrade to 3.2 from 3.1 "WARNING: A deprecated configuration key has been found. Please replace the deprecated key, 'rhevm', with the new one 'engine'"
RHEV message seen after upgrade to 3.2 from 3.1 "WARNING: A deprecated config...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-log-collector (Show other bugs)
3.2.0
Unspecified Unspecified
urgent Severity high
: ---
: 3.3.0
Assigned To: Sandro Bonazzola
Jiri Belka
integration
: Triaged, ZStream
Depends On:
Blocks: 1031092 1031094 1031604
  Show dependency treegraph
 
Reported: 2013-11-11 18:28 EST by Michael Everette
Modified: 2014-01-21 12:00 EST (History)
11 users (show)

See Also:
Fixed In Version: rhevm-log-collector-3.3.1-4.el6ev
Doc Type: Bug Fix
Doc Text:
When running rhevm-image-uploader on a system upgraded from Red Hat Enterprise Virtualization 3.1 a warning was issued that a deprecated configuration key had been found. The legacy keyword 'rhevm' has been removed from the tool's configuration files, so the warning is not issued anymore.
Story Points: ---
Clone Of:
: 1031092 1031094 1031604 (view as bug list)
Environment:
Last Closed: 2014-01-21 12:00:59 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 413563 None None None Never
oVirt gerrit 21209 None None None Never
oVirt gerrit 21227 None None None Never

  None (edit)
Description Michael Everette 2013-11-11 18:28:11 EST
After upgrading from 3.1 to 3.2 the following is seen:

    When running rhevm-log-collector collect I get the following error.

WARNING: A deprecated configuration key has been found. Please replace the deprecated key, 'rhevm', with the new one 'engine' 
in /etc/ovirt-engine/logcollector.conf

    When running rhevm-iso-uploader I get the following error.

WARNING: A deprecated configuration key has been found. Please replace the deprecated key, 'rhevm', with the new one 'engine' 
in /etc/ovirt-engine/isouploader.conf

    When running rhevm-image-uploader I get the following error.

WARNING: A deprecated configuration key has been found. Please replace the deprecated key, 'rhevm', with the new one 'engine' 
in /etc/ovirt-engine/imageuploader.conf


This doesn't keep these from running but shouldn't the setup script change this so that the user does not see the change or beleive something is broken.
Comment 6 Sandro Bonazzola 2013-11-13 08:45:40 EST
Ideally customers should have updated the conf files merging old config with new one in .rpmnew without the need of that warning at all. There's no plan right now to remove the support for the backward compatibility.
Comment 16 Jiri Belka 2013-11-20 07:47:43 EST
ok is24, rhevm-log-collector-3.3.1-4.el6ev.noarch.rpm to rhevm-log-collector-3.3.1-4.el6ev.noarch. rhevm=jb-rh33.rhev.lab.eng.brq.redhat.com:443 used and no WARNING was seen.
Comment 17 Charlie 2013-11-27 20:16:50 EST
This bug is currently attached to errata RHBA-2013:15255. If this change is not to be documented in the text for this errata please either remove it from the errata, set the requires_doc_text flag to 
minus (-), or leave a "Doc Text" value of "--no tech note required" if you do not have permission to alter the flag.

Otherwise to aid in the development of relevant and accurate release documentation, please fill out the "Doc Text" field above with these four (4) pieces of information:

* Cause: What actions or circumstances cause this bug to present.
* Consequence: What happens when the bug presents.
* Fix: What was done to fix the bug.
* Result: What now happens when the actions or circumstances above occur. (NB: this is not the same as 'the bug doesn't present anymore')

Once filled out, please set the "Doc Type" field to the appropriate value for the type of change made and submit your edits to the bug.

For further details on the Cause, Consequence, Fix, Result format please refer to:

https://bugzilla.redhat.com/page.cgi?id=fields.html#cf_release_notes 

Thanks in advance.
Comment 18 errata-xmlrpc 2014-01-21 12:00:59 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0039.html

Note You need to log in before you can comment on or make changes to this bug.