Bug 102977 - TB maindialog.py:1065:on_hostsAddButton_clicked:NameError: global name 'Host' is not defined
TB maindialog.py:1065:on_hostsAddButton_clicked:NameError: global name 'Host'...
Status: CLOSED DUPLICATE of bug 102154
Product: Red Hat Linux Beta
Classification: Retired
Component: redhat-config-network (Show other bugs)
beta1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks: CambridgeBlocker
  Show dependency treegraph
 
Reported: 2003-08-23 21:36 EDT by Larry Reaves
Modified: 2007-04-18 12:57 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:58:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Larry Reaves 2003-08-23 21:36:25 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030703
Epiphany/0.8.0

Description of problem:
While on the hosts tab if you click on new redhat-config-network crashes

Version-Release number of selected component (if applicable):
redhat-config-network-1.3.1-1

How reproducible:
Always

Steps to Reproduce:
1.run redhat-config-network
2.click on hosts tab
3.click new
    

Actual Results:  It crashed

Expected Results:  A dialog should open that allows me to enter host information

Additional info:

Component: redhat-config-network
Version: 1.3.1
Summary: TB maindialog.py:1065:on_hostsAddButton_clicked:NameError: global name
'Host' is not defined
Traceback (most recent call last):
  File
"/usr/src/build/273296-noarch/install/usr/share/redhat-config-network/netconfpkg/gui/maindialog.py",
line 611, in on_addButton_clicked
  File
"/usr/src/build/273296-noarch/install/usr/share/redhat-config-network/netconfpkg/gui/maindialog.py",
line 1065, in on_hostsAddButton_clicked
NameError: global name 'Host' is not defined

Local variables in innermost frame:
hostslist: HostsList.1.IP=127.0.0.1
HostsList.1.Hostname=localhost.localdomain
HostsList.1.AliasList.1=localhost
HostsList.2.IP=192.168.1.1
HostsList.2.Hostname=valkyrie.moonshinecomputers.org
HostsList.2.AliasList.1=valkyrie
HostsList.2.AliasList.2=indexsrv
HostsList.2.AliasList.3=server1

profilelist: ProfileList.default.HostsList.1.IP=127.0.0.1
ProfileList.default.HostsList.1.Hostname=localhost.localdomain
ProfileList.default.HostsList.1.AliasList.1=localhost
ProfileList.default.HostsList.2.IP=192.168.1.1
ProfileList.default.HostsList.2.Hostname=valkyrie.moonshinecomputers.org
ProfileList.default.HostsList.2.AliasList.1=valkyrie
ProfileList.default.HostsList.2.AliasList.2=indexsrv
ProfileList.default.HostsList.2.AliasList.3=server1
ProfileList.default.ActiveDevices.1=eth0
ProfileList.default.DNS.SecondaryDNS=
ProfileList.default.DNS.SearchList.1=moonshinecomputers.org
ProfileList.default.DNS.Domainname=
ProfileList.default.DNS.PrimaryDNS=192.168.1.1
ProfileList.default.DNS.Hostname=localhost.localdomain
ProfileList.default.DNS.TertiaryDNS=
ProfileList.default.Active=true
ProfileList.default.ProfileName=default

self: <netconfpkg.gui.maindialog.mainDialog instance at 0x9d57dd4>
args: (<gtk.Button object (GtkButton) at 0x9dd9abc>,)
curr_prof: Profile.HostsList.1.IP=127.0.0.1
Profile.HostsList.1.Hostname=localhost.localdomain
Profile.HostsList.1.AliasList.1=localhost
Profile.HostsList.2.IP=192.168.1.1
Profile.HostsList.2.Hostname=valkyrie.moonshinecomputers.org
Profile.HostsList.2.AliasList.1=valkyrie
Profile.HostsList.2.AliasList.2=indexsrv
Profile.HostsList.2.AliasList.3=server1
Profile.ActiveDevices.1=eth0
Profile.DNS.SecondaryDNS=
Profile.DNS.SearchList.1=moonshinecomputers.org
Profile.DNS.Domainname=
Profile.DNS.PrimaryDNS=192.168.1.1
Profile.DNS.Hostname=localhost.localdomain
Profile.DNS.TertiaryDNS=
Profile.Active=true
Profile.ProfileName=default
Comment 1 Harald Hoyer 2003-08-24 19:06:25 EDT

*** This bug has been marked as a duplicate of 102154 ***
Comment 2 Red Hat Bugzilla 2006-02-21 13:58:13 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.