Bug 1030182 - project version with unspecified project type should be copied once project-type of the project is set
project version with unspecified project type should be copied once project-t...
Status: CLOSED DUPLICATE of bug 1088737
Product: Zanata
Classification: Community
Component: Component-Logic (Show other bugs)
3.1
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Damian Jansen
Zanata-QA Mailling List
:
: 959813 (view as bug list)
Depends On:
Blocks: 1030166
  Show dependency treegraph
 
Reported: 2013-11-14 00:19 EST by Ding-Yi Chen
Modified: 2014-04-23 02:24 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-04-23 02:24:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ding-Yi Chen 2013-11-14 00:19:12 EST
Description of problem:

It is possible that project has project-type, while its version has not.
If that is the case, in project version view, the project-type shows its parent's project-type, while zanata.xml does not include such information.

Version-Release number of selected component (if applicable):
Zanata version 3.2-SNAPSHOT (20131114-0037)


How reproducible:
Always, if Bug 1030166 is not fixed.

Steps to Reproduce:
1. Create a project without project-type
2. Create a version (VER1) of that project without project-type
3. Go to project view, click "Edit project"
4. Change project type to "podir", and click "Update"
5. Go to the version VER1
6. Click "Config file"

Actual results:
After step 5, the project-type of project version VER1 is podir
After step 6, the project-type in zanata.xml is undefined.

Expected results:
After step 5, the project-type of project version VER1 is podir
After step 6, the project-type in zanata.xml is podir.


Additional info:
Comment 1 Sean Flanigan 2013-11-14 19:44:51 EST
Also: In this situation, actions like download as ZIP are disabled too, even though the project iteration type *appears* to be set in the GUI.
Comment 2 Sean Flanigan 2013-11-15 01:09:06 EST
If the Project Version's projectType is not set, it should be shown as blank/null in the Edit Version page.  It should not simply show the Project's type, because that is misleading.  (The blank projectType could be supplemented with a note to remind the user what the Project's projectType is.)
Comment 3 Damian Jansen 2014-03-06 18:48:01 EST
I think Luke's changes to the project pages handle some of the above.

Changing the behaviour of this bug would be contrary to the original design, assuming No Selection is a valid type.
Comment 4 Ding-Yi Chen 2014-03-23 23:34:05 EDT
*** Bug 959813 has been marked as a duplicate of this bug. ***
Comment 5 Ding-Yi Chen 2014-04-23 02:24:57 EDT

*** This bug has been marked as a duplicate of bug 1088737 ***

Note You need to log in before you can comment on or make changes to this bug.