Bug 1030658 - RHOS should use impl_qpid v2 by default
RHOS should use impl_qpid v2 by default
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-nova (Show other bugs)
4.0
All Linux
high Severity high
: rc
: 4.0
Assigned To: Xavier Queralt
Ami Jeain
:
: 1030664 (view as bug list)
Depends On:
Blocks: 1030664 1031022 1031023 1031025 1031027
  Show dependency treegraph
 
Reported: 2013-11-14 16:22 EST by Alvaro Lopez Ortega
Modified: 2016-04-26 14:04 EDT (History)
15 users (show)

See Also:
Fixed In Version: openstack-nova-2013.2-5.el6ost
Doc Type: Bug Fix
Doc Text:
The QPID driver's v2 topology was introduced to specifically address the slow growth of orphaned direct exchanges over time. By default, however, services still use the original v1 topology of the QPID driver; the v2 topology has to be explicitly configured via the 'qpid_topology_version = 2' parameter. With this fix, the Compute service's distribution configuration file (/usr/share/nova/nova-dist.conf) now contains the 'qpid_topology_version = 2' parameter. This effectively sets the QPID driver's v2 topology as the default.
Story Points: ---
Clone Of:
: 1030664 1031022 1031023 1031025 1031027 (view as bug list)
Environment:
Last Closed: 2013-12-19 19:35:49 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alvaro Lopez Ortega 2013-11-14 16:22:44 EST
Description of problem:
Packstack does not touch the default value of 'qpid_topology_version', which defaults to 1. It should set it to 2, so Qpid's topology v2 was used.

How reproducible:
Check /etc/ceilometer/ceilometer.conf, /etc/cinder/cinder.conf, /etc/nova/nova.conf, etc.

Expected results:
An entry "qpid_topology_version=2"
Comment 2 Perry Myers 2013-11-14 17:11:54 EST
Based on a comment russellb made earlier regarding a different but related issue... should we not just change this in the dist conf files for each of these projects?

That would make this less of a packstack issue perhaps and just a single bug on each of the projects (nova, heat, ceilometer, cinder) to change the default dist conf
Comment 3 Alvaro Lopez Ortega 2013-11-15 08:38:09 EST
@pmyers: I agree. It sounds like a much more sane approach.
Comment 4 Alvaro Lopez Ortega 2013-11-15 08:46:45 EST
Oops! I meant to reassign it to Nova. Sorry for that.
Comment 6 Ami Jeain 2013-11-26 15:53:05 EST
failed QA:

# grep -R qpid_topology_version /etc
grep: /etc/httpd/run/wsgi.26690.1.1.sock: No such device or address
/etc/ceilometer/ceilometer.conf:#qpid_topology_version=1
/etc/heat/heat.conf.bak:#qpid_topology_version=1
/etc/heat/heat.conf:#qpid_topology_version=1
/etc/nova/nova.conf:#qpid_topology_version=1
/etc/cinder/cinder.conf:#qpid_topology_version=1

# rpm -qa |grep openstack-nova
openstack-nova-api-2013.2-5.el6ost.noarch
openstack-nova-console-2013.2-5.el6ost.noarch
openstack-nova-compute-2013.2-5.el6ost.noarch
openstack-nova-scheduler-2013.2-5.el6ost.noarch
openstack-nova-common-2013.2-5.el6ost.noarch
Comment 7 Xavier Queralt 2013-11-29 02:21:02 EST
@Ami, the key is set in the nova-dist.conf file under /usr/share/nova. Sorry for not mentioning this before.

[root@rhos1 ~]# rpm -qa openstack-nova-common
openstack-nova-common-2013.2-5.el6ost.noarch

[root@rhos1 ~]# grep -R qpid_topology_version /usr/share/nova/
/usr/share/nova/nova-dist.conf:qpid_topology_version=2
Comment 8 Ami Jeain 2013-12-01 03:28:48 EST
verified:

# rpm -qa openstack-nova-common
openstack-nova-common-2013.2-5.el6ost.noarch

#  grep -R qpid_topology_version /usr/share/nova/
/usr/share/nova/nova-dist.conf:qpid_topology_version=2
Comment 9 Alan Pevec 2013-12-05 13:11:37 EST
(In reply to Xavier Queralt from comment #7)
> @Ami, the key is set in the nova-dist.conf file under /usr/share/nova. Sorry
> for not mentioning this before.

But commented default in nova.conf should be changed too to reflect dist.conf default!
Comment 12 Xavier Queralt 2013-12-17 08:24:24 EST
(In reply to Alan Pevec from comment #9)
> (In reply to Xavier Queralt from comment #7)
> > @Ami, the key is set in the nova-dist.conf file under /usr/share/nova. Sorry
> > for not mentioning this before.
> 
> But commented default in nova.conf should be changed too to reflect
> dist.conf default!

Argh, I forgot to update this. I will do it for the async release.
Comment 14 errata-xmlrpc 2013-12-19 19:35:49 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1859.html
Comment 15 Xavier Queralt 2014-01-16 08:20:27 EST
*** Bug 1030664 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.