Bug 1031025 - RHOS should use impl_qpid v2 by default
RHOS should use impl_qpid v2 by default
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-neutron (Show other bugs)
4.0
All Linux
high Severity high
: rc
: 4.0
Assigned To: Jakub Libosvar
Rami Vaknin
:
Depends On: 1030658 1031027
Blocks: 1030664 1031022 1031023
  Show dependency treegraph
 
Reported: 2013-11-15 08:49 EST by Alvaro Lopez Ortega
Modified: 2016-04-26 21:43 EDT (History)
14 users (show)

See Also:
Fixed In Version: openstack-neutron-2013.2-9.el6ost
Doc Type: Bug Fix
Doc Text:
The QPID driver's v2 topology was introduced to specifically address the slow growth of orphaned direct exchanges over time. By default, however, services still use the original v1 topology of the QPID driver; the v2 topology has to be explicitly configured via the 'qpid_topology_version = 2' parameter. With this fix, the Networking service's distribution configuration file (/usr/share/neutron/neutron-dist.conf) now contains the 'qpid_topology_version = 2' parameter. This effectively sets the QPID driver's v2 topology as the default.
Story Points: ---
Clone Of: 1030658
Environment:
Last Closed: 2013-12-19 19:36:18 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 4 Terry Wilson 2013-11-19 13:19:18 EST
*** Bug 1032151 has been marked as a duplicate of this bug. ***
Comment 6 Rami Vaknin 2013-12-05 03:09:30 EST
Failed verification.

rhos 4.0 on rhel6.5, puddle 2013-11-26.3
openstack-neutron-2013.2-10.el6ost.noarch
openstack-heat-api-2013.2-1.0.el6ost.noarch
openstack-nova-api-2013.2-5.el6ost.noarch

It looks like the "qpid_topology_version=2" was applied only on nova and neutron while at least on heat and cinder it was not applied. I had issues with ceilometer installation so I don't know what's the status there.

The "qpid_topology_version=2" appears only in nova and neutron dist files:

# grep -R qpid_topology_version /usr/share/
/usr/share/nova/nova-dist.conf:qpid_topology_version=2
/usr/share/neutron/neutron-dist.conf:qpid_topology_version = 2

# grep -R qpid_topology_version /etc/
/etc/heat/heat.conf:#qpid_topology_version=1
/etc/heat/heat.conf.bak:#qpid_topology_version=1
/etc/cinder/cinder.conf:#qpid_topology_version=1
/etc/nova/nova.conf:#qpid_topology_version=1

I've also enabled debug in the projects and found "amq.topic" only in nova and neutron logs.
Comment 7 Jakub Libosvar 2013-12-05 03:21:47 EST
This bug fixes neutron only (like bug 1030658 fixes nova only). Feel free to open new bugs to components that doesn't use qpid_topology_version 2. Note that some of bugs are already opened: bug 1031023, bug 1031022, bug 1030664.
Comment 8 Rami Vaknin 2013-12-05 03:41:49 EST
Moving to Verified based on comments #6+#7.
Comment 11 errata-xmlrpc 2013-12-19 19:36:18 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1859.html

Note You need to log in before you can comment on or make changes to this bug.