Bug 1030664 - RHOS should use impl_qpid v2 by default
RHOS should use impl_qpid v2 by default
Status: CLOSED DUPLICATE of bug 1030658
Product: RDO
Classification: Community
Component: openstack-nova (Show other bugs)
unspecified
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: RHOS Maint
Ami Jeain
:
Depends On: 1030658 1031022 1031023 1031025 1031027
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-14 16:28 EST by Alvaro Lopez Ortega
Modified: 2014-01-16 08:20 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
The QPID driver's v2 topology was introduced to specifically address the slow growth of orphaned direct exchanges over time. By default, however, services still use the original v1 topology of the QPID driver; the v2 topology has to be explicitly configured via the 'qpid_topology_version = 2' parameter. To address this, Packstack now adds the 'qpid_topology_version = 2' parameter to the distribution configuration file of each service (e.g. /usr/share/neutron/neutron-dist.conf). This effectively sets the QPID driver's v2 topology as the default.
Story Points: ---
Clone Of: 1030658
Environment:
Last Closed: 2014-01-16 08:20:27 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alvaro Lopez Ortega 2013-11-14 16:28:42 EST
+++ This bug was initially created as a clone of Bug #1030658 +++

Description of problem:
Packstack does not touch the default value of 'qpid_topology_version', which defaults to 1. It should set it to 2, so Qpid's topology v2 was used.

How reproducible:
Check /etc/ceilometer/ceilometer.conf, /etc/cinder/cinder.conf, /etc/nova/nova.conf, etc.

Expected results:
An entry "qpid_topology_version=2"
Comment 1 Alvaro Lopez Ortega 2014-01-15 08:15:09 EST
It's actually an openstack-nova bug - at I believe has been fixed already. I'm reassigning it just in case.
Comment 2 Xavier Queralt 2014-01-16 08:20:27 EST
This was already fixed in nova.

*** This bug has been marked as a duplicate of bug 1030658 ***

Note You need to log in before you can comment on or make changes to this bug.