Bug 1035325 - Don't print IzPack variables to console.
Summary: Don't print IzPack variables to console.
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Installer
Version: 6.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: EAP 6.3.0
Assignee: Thomas Hauser
QA Contact: Petr Kremensky
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-11-27 14:50 UTC by Petr Kremensky
Modified: 2017-10-10 00:13 UTC (History)
1 user (show)

(edit)
In this release of JBoss EAP 6, the installer will no longer log all of IzPack's internal variables to the console. They are now only logged within the log file.
Clone Of:
(edit)
Last Closed: 2014-05-02 12:46:52 UTC


Attachments (Terms of Use)

Description Petr Kremensky 2013-11-27 14:50:54 UTC
Description of problem:
We should make the installer console less verbose. As a result BZ1016652, and BZ1019160 installer store all installation related information into InstallationLog.txt, but these information are also printed to console. This is causing the most of console installation output to be IzPack variables, which aren't really that important to user. 

Version-Release number of selected component (if applicable):
 EAP 6.2.0.CR3.1

How reproducible:
 Always

Steps to Reproduce:
 1. Run the console installation.
 2. Don't do anything special, just finish the installation using default values where possible.
 3. Observer the installer output.

Actual results (IzPack variables are stored into InstallationLog.txt and printed on console):
...
[ Starting processing ]
Starting process Logging installation information (1/4)
standalone.h.ajp = 8009
...
lot of IzPack variables here
...
domain.h.jgroups-tcp = 7600
IzPack variable state written to /home/pkremens/EAP-6.2.0/InstallationLog.txt
Starting process Adding Post-Install User (2/4)
Starting process Running Password Script (3/4)
Successfully added administrative user account.
Starting process Unpacking natives (4/4)
Unpacking complete.
Create shortcuts in the Start-Menu (y/n) [y]:
...

Expected results (IzPack variables are stored into InstallationLog.txt):
...
[ Starting processing ]
Starting process Logging installation information (1/4)
IzPack variable state written to /home/pkremens/EAP-6.2.0/InstallationLog.txt
Starting process Adding Post-Install User (2/4)
Starting process Running Password Script (3/4)
Successfully added administrative user account.
Starting process Unpacking natives (4/4)
Unpacking complete.
Create shortcuts in the Start-Menu (y/n) [y]:
...

Additional info:
 - This enhancement request is related only to this specific part of installation (process Logging installation information). Printing other data into console (post-install actions, etc) is quite useful and I would like to retain it. 
 - Do the same for gui installation.
 - Is this possible with IzPack?

Comment 1 Thomas Hauser 2013-11-27 15:04:17 UTC
The reason for this verbosity is because of the inflexibility of the jboss-cli API we are using. It only allows output to standard out.

Comment 2 Petr Kremensky 2014-05-02 12:46:52 UTC
EAP 6.3.0 installer is not so verbose as was the 6.2.0.

Closing this.

Comment 3 Thomas Hauser 2014-05-02 13:23:05 UTC
Just making a note: The IzPack variables are still present in the log, so no information is lost, just the excessive printing to console (this was to workaround an issue with the jboss-cli, but due to other changes is no longer necessary. :) )


Note You need to log in before you can comment on or make changes to this bug.