This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1247240 - Thinkpad t440s freezes in Ultra Dock with external monitors
Thinkpad t440s freezes in Ultra Dock with external monitors
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
23
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On: 1036974
Blocks:
  Show dependency treegraph
 
Reported: 2015-07-27 11:43 EDT by Tom "spot" Callaway
Modified: 2015-10-20 08:58 EDT (History)
26 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1036974
Environment:
Last Closed: 2015-10-20 08:58:26 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg log with drm.debug=14 on kernel 4.2.1-300.fc23 (83.07 KB, application/x-gzip)
2015-09-29 10:21 EDT, Tom "spot" Callaway
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 91476 None None None Never

  None (edit)
Description Tom "spot" Callaway 2015-07-27 11:43:23 EDT
+++ This bug was initially created as a clone of Bug #1036974 +++

Description of problem:

The Ultradock bug is back! Essentailly, this is the same problem as reported in the past on Bug #1036974 and Bug #1035448.

I have a Lenovo T440s, running BIOS GJET84WW (2.34 ). I have an Ultradock for it. When I have a monitor connected to the Ultradock, Linux freezes. This happens very early if I try to boot on the dock, and if I boot undocked, then dock the laptop, it freezes. Disconnecting the monitor from the Ultradock resolves this issue.

Lenovo released a firmware update for the Ultradock which I applied a long time ago. (You can only apply this from Windows, I borrowed a windows T440s to update the ultradock firmware). Since then, Fedora 21 and 22 have been working perfectly, but on Fedora 23 kernels, it has broken again. Tested:

kernel-4.2.0-0.rc2.git1.1.fc23.x86_64
kernel-4.2.0-0.rc3.git2.1.fc23.x86_64
kernel-4.2.0-0.rc3.git4.1.fc23.x86_64
Comment 1 Tom "spot" Callaway 2015-07-27 11:44:35 EDT
I'm wondering if a patch got lost somewhere in the 4.2 cycle.
Comment 2 Tom "spot" Callaway 2015-09-29 10:21 EDT
Created attachment 1078383 [details]
dmesg log with drm.debug=14 on kernel 4.2.1-300.fc23

This continues to be broken with current kernels. I put the Thinkpad in the dock, booted up with drm.debug=14. Plymouth (the graphical boot screen in Fedora) loads up properly on both monitors, but when it drops to the gdm login screen, it only shows up on the laptop panel (the external monitor is black). GNOME slowly loads, but when I bring up the display control panel, it seems to freeze but eventually shows me that it can see the external display, but no matter what I do, it cannot output to it.

As a reminder, when I undock the laptop and connect the external monitor to the VGA port, it works as expected.

I had to gz the dmesg log file due to its size, there is a LOT of noise in there.
Comment 3 Justin M. Forbes 2015-09-30 10:50:18 EDT
I believe this has been fixed with kernel 4.2.2-300. Would you mind testing and letting me know?
Comment 4 Tom "spot" Callaway 2015-10-20 08:58:26 EDT
Confirmed as fixed. Sorry it took so long to test this, but I have been away from my desk (where the dock lives).

Note You need to log in before you can comment on or make changes to this bug.