Bug 103724 - xrandr messes up screensaver
xrandr messes up screensaver
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: xscreensaver (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
:
: 100619 109277 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-09-04 08:57 EDT by Alexander Larsson
Modified: 2007-04-18 12:57 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-22 10:39:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexander Larsson 2003-09-04 08:57:51 EDT
I changed my resolution in gnome-display-properties to 800x600, loged out and in
again. Now gnome-session set my resolution to 800x600. Then i changed back to
the default size (1024x768), and when the screensaver turned on it was only
covering the top-left 800x600.
Comment 1 Mike A. Harris 2003-09-04 09:52:26 EDT
alex:  How did the resolution get changed?  Via the RandR extension?
Comment 2 Alexander Larsson 2003-09-04 09:55:36 EDT
Yes.
Comment 3 Bill Nottingham 2003-09-04 14:11:20 EDT
What does XF86VidModeGetViewPort return (see #81593)?
Comment 4 Alexander Larsson 2003-09-05 06:36:41 EDT
It returns "0,0", and the viewport is correctly placed at 0,0. 

This is pretty easy to reproduce:
killall xscreensaver
xrandr -s 800x600
xscreensaver&
xrandr -s 1024x768
<wait for screensaver to start, or preview it in the xscreensaver-demo app>

Notice that the screensaver is only 800x600.
Restarting xscreensave fixes the problem. I think xscreensaver needs to listen
to XRandR events so it can know when the screen changes size.
Comment 5 Bill Nottingham 2003-10-31 12:08:29 EST
*** Bug 100619 has been marked as a duplicate of this bug. ***
Comment 6 Jef Spaleta 2004-02-27 12:48:12 EST
*** Bug 109277 has been marked as a duplicate of this bug. ***
Comment 7 Ray Strode [halfline] 2004-06-21 12:01:34 EDT
jwz's changelog page has this for the latest version of xscreensaver:

* Added support for the RANDR (Resize and Rotate) extension to detect
when the size of the desktop has been changed while xscreensaver is
already running.

I'll roll out new rawhide rpms soon.
Comment 8 Ray Strode [halfline] 2004-06-22 10:39:40 EDT
This should be fixed in rawhide now.

Note You need to log in before you can comment on or make changes to this bug.