Bug 103735 - RFE: mhash support in PHP
RFE: mhash support in PHP
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: distribution (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-09-04 09:52 EDT by Leonard den Ottolander
Modified: 2014-03-16 22:38 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-07 15:17:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
libmhash.spec (1.85 KB, text/plain)
2003-09-04 09:53 EDT, Leonard den Ottolander
no flags Details

  None (edit)
Description Leonard den Ottolander 2003-09-04 09:52:13 EDT
Currently PHP is shipped without mhash support. Adding mhash support requires
adding of a libmhash rpm to the distribution and configuring PHP with --with-mhash.

The mhash source can be found at
http://prdownloads.sourceforge.net/mhash/mhash-0.8.18.tar.gz?download

 A spec file for libmhash can be found here:
http://home.hetnet.nl/~ottolander/mhash/libmhash.html
(I will add the spec file as an attachment.)
Comment 1 Leonard den Ottolander 2003-09-04 09:53:12 EDT
Created attachment 94199 [details]
libmhash.spec
Comment 2 Joe Orton 2003-09-07 18:19:51 EDT
First you must request separately for mhash to be added to the distribution.

I don't particularly support this: mhash doesn't seem to do much that OpenSSL
doesn't; you could extend the existing PHP openssl extension to achieve the same
functionality without needing extra packages, I would think.
Comment 3 Leonard den Ottolander 2003-09-07 19:28:46 EDT
Maybe I should take a closer look at openssl, but it doesn't look like the PHP
openssl interface currently makes it easy to use all the different encryption
algorithms that mhash supports (have a quick look at
http://mhash.sourceforge.net and the PHP4 documentation). Also it looks like the
openssl functions use keys for encryption/hashing, which are not needed by the
algorithms supported by mhash. F.e. how do I calculate an md5sum using openssl?

How would I submit a request for adding (lib)mhash support to the distro? Also
note that the library is only about 150K and PHP already has an interface to use it.
Comment 4 Leonard den Ottolander 2004-01-26 07:06:45 EST
Changed product from Red Hat Linux Beta to Fedora Core 1, as it still
is an issue there.
Comment 5 Aleksander Adamowski 2004-10-20 05:17:36 EDT
I'd like to support this change request, with RHEL 4 release as the
target platform.

We are using LDAP extensively in our organisation and plan offer
LDAP-enabled solutions to many customers. Most of available LDAP-aware
applications written in PHP use mhash PHP extension for password
hashing (among others phpLDAPadmin).

Lack of libmhash and php-mhash support in RHEL forces us to lean
towards using Suse and other distributions because for production
systems we need those packages to be _vendor-supported_, not home-made.

Adding php-mhash support would be extremely easy (the official
redhat/fedora RPM has a '--with-mhash' conditional now, see bug
111251) and it is a good time to get them included in RHEL 4 which is
is in beta phase yet.

IMO, this is an important feature for a corporate distribution since
it is significat in LDAP-based environments.

In addition, please note that almost all other distributions ship with
mhash by default: Mandrake, SuSe, Debian.

Even such a minimal system as OpenBSD, which refuses to put Midnight
Commander in its ports tree, has mhash and php-mhash in ports.
Comment 6 Aleksander Adamowski 2004-10-20 05:25:17 EDT
I'd like to signify the importance of this for corporate customers
using RHEL, what is the best method?

Should I open a RHEL support ticket?
Comment 7 Bill Nottingham 2004-10-20 14:00:42 EDT
That's probably best.
Comment 8 Aleksander Adamowski 2004-10-21 04:22:34 EDT
I've opened service request 369868 as an addition to this bug.
Comment 9 Leonard den Ottolander 2004-10-23 10:36:40 EDT
Please also compare bug 104211, bug 114294, bug 114295 and bug 114297.
Comment 10 Daniel Rogers 2004-12-07 19:48:53 EST
I'd just like to give a "me too" on this one.  Having mcrypt/mhash and
php-mcrypt/php-mhash in the standard FC distro would make my life a
lot easier.

Dan.
Comment 11 Bill Nottingham 2005-10-07 15:17:02 EDT
Realistically, as mhash/mcrypt is in Extras, php-m* is unlikely to be added to core.

Note You need to log in before you can comment on or make changes to this bug.