Bug 103846 - Software RAID not detected on RH9 upgrade
Software RAID not detected on RH9 upgrade
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
9
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-09-05 13:18 EDT by Thomas Smith
Modified: 2007-04-18 12:57 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-09-29 12:56:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thomas Smith 2003-09-05 13:18:08 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4) Gecko/20030624

Description of problem:
I have a Redhat 7.2 server using software RAID.  When I run the RH9 installation
by booting from either floppy or CD it doesn't detect the RAID devices.

The kernel seems to know that they're there but doesn't mount them. When the
install starts it tells me that no valid installation devices w detected and
asks me to select one of the /dev/hd* partitions.

I tried using the Update Disk suggested in Bug 65192 (this was for RH7.3) but
got many anaconda errors and the installation halted.

I also posted a comment on Bug 89863 as this issues seems very similar to the
problem I'm having. This Bug hasn't been addressed in some time so I don't know
if a resolution was reached or not.

Version-Release number of selected component (if applicable):

How reproducible:
Always

Steps to Reproduce:
1. Boot RH9 install from floppy.
2. Type "linux text"
3. Select "FTP" as the installation media.

Actual Results:  When the installation initializes it will indicate that there
are no valid installation devices and prompt me to select one--the options I
have are the /dev/hd* devices that comprise the RAID arrays. It doesn't,
however, give me an option to select any of the /dev/md* devices.

Expected Results:  Anaconda should detect and mount the RAID devices and proceed
with the installation/upgrade.

Additional info: Since I haven't had many problems with Redhat's installation
routine I'm not real familiar with troubleshooting it. Please let me know if
there's any additional information I can provide about the install, log files,
or whatnot so I can do so.
Comment 1 Thomas Smith 2003-09-09 11:56:41 EDT
This issue has been worked around.

The problem is that the floppy boot disk doesn't properly mount the RAID partitions.

Further, since I have four IDE drives in each server, I had to install, in this
case, a SCSI CD-ROM in order to upgrade. If I tried removing one of the drive
and running the upgrade with a degraded RAID array it wouldn't work--Anaconda
couldn't mount the degraded array.

Is there a way to work around the floppy problem while still running the setup
from a floppy boot disk? As I perceive it, the floppy simply doesn't have enough
space to load such utilities as raidstart and therefore can't mount RAID
partitions. If this is the case, can a multi-disk floppy-based install disk be
created to load some of the essentials for mounting RAID and LVM partitions, for
example.
Comment 2 Jeremy Katz 2003-09-29 12:56:06 EDT
There's no way for us to fit everything we use for RAID and LVM initialization
and detection on floppies.  Hard drive installs can only be supported from
actual physical disks.

Note You need to log in before you can comment on or make changes to this bug.