Bug 103871 - rhn-applet-gui does not load
rhn-applet-gui does not load
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: rhn-applet (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Veillard
:
: 103878 (view as bug list)
Depends On:
Blocks: CambridgeBlocker
  Show dependency treegraph
 
Reported: 2003-09-05 18:00 EDT by Kyle R Maxwell
Modified: 2007-04-18 12:57 EDT (History)
1 user (show)

See Also:
Fixed In Version: 2.0.10-6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-09-07 12:49:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Kyle R Maxwell 2003-09-05 18:00:08 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5a) Gecko/20030729
Mozilla Firebird/0.6.1

Description of problem:
rhn-applet-gui does not load when I start a GNOME session. If I load it from a
command line, it fails as well. The notification area does apparently load.

Version-Release number of selected component (if applicable):
rhn-applet-2.0.10-4

How reproducible:
Always

Steps to Reproduce:
1. Run rhn-applet-gui, either from command line or in the normal session.
2.
3.
    

Actual Results:  Program does not load.

Additional info:

When trying to start from the command line, I get the following errors:

Traceback (most recent call last):
  File "/usr/bin/rhn-applet-gui", line 41, in ?
    main()
  File "/usr/bin/rhn-applet-gui", line 37, in main
    applet = rhn_applet.rhnApplet()
  File "/usr/bin/../share/rhn/rhn_applet/rhn_applet.py", line 143, in __init__
    self.session = gnome.ui.gnome_master_client()
AttributeError: 'module' object has no attribute 'gnome_master_client'
Comment 1 Kyle R Maxwell 2003-09-05 21:27:18 EDT
OK, maybe this is getting weird: after downgrading to gnome-panel-2.3.7-1 and
rhn-applet-2.0.10-1, I still have the bug. It must be in some other package, but
I'm not sure which one.
Comment 2 Bill Nottingham 2003-09-06 00:07:43 EDT
*** Bug 103878 has been marked as a duplicate of this bug. ***
Comment 3 Miloš Komarčević 2003-09-06 20:20:02 EDT
I can confirm this with 2.0.10-5 and Gnome updated to latest rawhide.
Comment 4 Daniel Veillard 2003-09-07 05:50:53 EDT
it's a change in the gtk python bindings. Please try 2.0.10-6 
at http://people.redhat.com/~veillard/

Daniel
Comment 5 Kjartan Maraas 2003-09-07 06:11:31 EDT
I can add it now and it doesn't crash. Will try logging in again to see what
happens then.
Comment 6 Kjartan Maraas 2003-09-07 06:17:40 EDT
Works for me. This also fixes the high CPU load on login it seems, but that
might be related to first time login or something. I'll investigate more later.
Comment 7 Kyle R Maxwell 2003-09-07 10:44:53 EDT
2.0.10-6 seems to do the trick; no problem loading it now either from the
command line or automatically on session start. Thanks for the help and the
weekend fix!
Comment 8 Miloš Komarčević 2003-09-07 12:31:37 EDT
Works here as well, thanks.
Comment 9 Daniel Veillard 2003-09-07 12:49:40 EDT
Excellent, the update has been pushed to rawhide, it will be in the
next release.

  Thanks a lot for the report,

Daniel

Note You need to log in before you can comment on or make changes to this bug.