Bug 103955 - NVidia Quadro4 NVS not probed
NVidia Quadro4 NVS not probed
Status: CLOSED DUPLICATE of bug 67193
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
Depends On:
  Show dependency treegraph
Reported: 2003-09-08 08:48 EDT by Dimitri Papadopoulos
Modified: 2007-04-18 12:57 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-02-21 13:58:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
output of /sbin/lspci -v (5.70 KB, text/plain)
2003-09-08 08:52 EDT, Dimitri Papadopoulos
no flags Details
output of /sbin/lspci -vn (4.42 KB, text/plain)
2003-09-08 08:53 EDT, Dimitri Papadopoulos
no flags Details
XF86Config with 'nv' driver, doesn't work, changing to 'nvidia' works (3.17 KB, text/plain)
2003-09-09 07:49 EDT, Dimitri Papadopoulos
no flags Details
log of startx (1.94 KB, text/plain)
2003-09-09 08:31 EDT, Dimitri Papadopoulos
no flags Details
/var/log/XFree86.0.log (32.79 KB, text/plain)
2003-09-09 08:32 EDT, Dimitri Papadopoulos
no flags Details
/var/log/XFree86.0.log (32.72 KB, text/plain)
2003-09-09 09:35 EDT, Dimitri Papadopoulos
no flags Details
lsmod > lsmod.log (1.07 KB, text/plain)
2003-09-09 09:36 EDT, Dimitri Papadopoulos
no flags Details

  None (edit)
Description Dimitri Papadopoulos 2003-09-08 08:48:40 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030624

Description of problem:

The Red Hat 9 installation process does not recognize the NVidia Quadro 4 NVS card.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Install Red Hat 9 on a machine with a NVidia Quadro4 NVS card

Actual Results:  Intallation of X11 fails, card is not recognized.

Expected Results:  Card should be recognized as NVidia card.

Additional info:
Comment 1 Dimitri Papadopoulos 2003-09-08 08:52:48 EDT
Created attachment 94294 [details]
output of /sbin/lspci -v
Comment 2 Dimitri Papadopoulos 2003-09-08 08:53:12 EDT
Created attachment 94295 [details]
output of /sbin/lspci -vn
Comment 3 Dimitri Papadopoulos 2003-09-08 08:55:27 EDT
This card is now standard with Dell workstations.
This is a Dell Precision 650 workstation.
Comment 4 Mike A. Harris 2003-09-09 05:35:16 EDT
Please run the following:

redhat-config-xfree86 --reconfig

Attach the XFree86 config file that gets generated from this.  If it does
not autodetect, manually select any other Nvidia card from the card list,
and let me know if it works.

Currently, the "nv" driver has built in support for all known Nvidia chipsets
as of February this year, and also has support to autodetect unknown chips
from a known chip core (ie: NV18), so even chips that are not specifically
supported should be detected as "unknown NV18 chip" and the driver should
work anyway.

If you do get it to work, please attach the working config file and X server
log file, so I can update the driver appropriately and our hardware database.

Thanks in advance.
Comment 5 Dimitri Papadopoulos 2003-09-09 05:58:04 EDT
I'm not sure how redhat-config-xfree86 is supposed to work. It spits some error
messages, most of them probably because because the 1702FP flat panel display is
not recognized either (see bug #102892):

	# redhat-config-xfree86 --reconfig
	* ddcprobe returned bogus values:
	ID:   None
	Name: None
	HorizSync: None
	VertSync:  None
	Trying with card: NVIDIA Quadro 4 (generic)

I manually enter the display type. A new XF86Config file is generated. Please
find it attached.
Comment 6 Mike A. Harris 2003-09-09 07:40:42 EDT
I see no config file attached yet..  Please attach both the X config file
and log file that is generated from attempting to startx.
Comment 7 Dimitri Papadopoulos 2003-09-09 07:47:45 EDT
Mmmmh... We were actually using the 'nvidia' driver from nVidia on this machine,
not the 'nv' driver from XFree86.

Now 'redhat-config-xfree86 --reconfig' attempts to revert to the 'nv' driver
using 'NVIDIA Quadro 4 (generic)' but this doesn't seem to work. Well, XFree86
does run and doesn't report any errors, but I see only garbage on the screen.
Just changing from 'nv' back to 'nvidia' works just fine.

To tell the truth I don't mind that much, as I only need a basic XFree86
installation that just recognizes the card and the display. Then I install the
nVidia drivers anyway during post-installation in text-mode.

By the way, it's Quadro4, not Quadro 4.
Comment 8 Dimitri Papadopoulos 2003-09-09 07:49:01 EDT
Created attachment 94319 [details]
XF86Config with 'nv' driver, doesn't work, changing to 'nvidia' works
Comment 9 Dimitri Papadopoulos 2003-09-09 07:52:36 EDT
By the way, is 'NV18' the same as 'NVIDIA Quadro 4 (generic)'?
I can't find any reference to 'NV18'.
Comment 10 Dimitri Papadopoulos 2003-09-09 08:30:53 EDT
OK, I was getting additional errors because the nVidia drivers were still
installed. nVidia's GLX subsystem was complaining. I've now totally uninstalled
the nVidia drivers, so that we can focus on plain XFree86 issues.

Now I'm running 'startx' again. I still don't see anything on the screen,
because the monitor gets in "economy mode" (orange LED instead of green LED).
Switching back to console using Ctrl+F1, and switching the monitor off and back
on and I can see the console. Then switching back to graphic mode using Ctrl+F7,
 the monitor automatically gets into "economy mode".

The XFree86 log file shows no errors. See attached files.
Comment 11 Dimitri Papadopoulos 2003-09-09 08:31:35 EDT
Created attachment 94320 [details]
log of startx
Comment 12 Dimitri Papadopoulos 2003-09-09 08:32:44 EDT
Created attachment 94321 [details]
Comment 13 Mike A. Harris 2003-09-09 08:40:53 EDT
Please read bug #73733 first.  You are running XFree86 on a system which
has had unsupported Nvidia proprietary kernel modules loaded since the
last reboot.  This means that Nvidia's proprietary driver has modified the
video card's default power-on state.  This is not supported.

You must reinstall Red Hat supplied XFree86, because Nvidia's proprietary
drivers overwrite files that are shipped by Red Hat.  After reinstalling
Red Hat XFree86 packages using "rpm -Uvh --force XFree86*.i386.rpm", please
disable any kernel modules at boot time which are not supplied by Red Hat,
then reboot your system into a clean non-tainted kernel.  After performing
this, please run "startx" again, and then attach the output of the new
XFree86 log that gets generated, as well as your /var/log/messages file.

Comment 14 Mike A. Harris 2003-09-09 08:42:45 EDT
Also, once you've done the above, please run the following command as root:

rpm -V $(rpm -qa | grep XFree86) > rpm.log

Attach the rpm.log file that gets generated.

Thanks in advance.
Comment 15 Dimitri Papadopoulos 2003-09-09 08:48:13 EDT
I don't think I have to reinstall XFree86. I'm running
	nvidia-installer --uninstall
which uninstalls nVidia libraries and restores previous libraries.

I'll nevertheless reinstall XFree86 just to make sure. You never know, there
could be bugs in nvidia-installer.

Comment 16 Dimitri Papadopoulos 2003-09-09 09:33:24 EDT

Here is what I'm doing:

1) run 'init 3' to getinto text mode

2) modify /etc/inittab to that I reboot into text mode

3) startx (still using the nVidia drivers)

4) run redhat-config-xfree86 --reconfig, select monitor Dell 1702FP, use
autoprobed 'nv' driver for 'NVIDIA Quadro 4 (Generic)' video card. See attached
XF86Config file.

5) nvidia-install --uninstall

6) rpm -Uvh --force XFree86*.i386.rpm

7) rpm -V $(rpm -qa | grep XFree86) > rpm.log
   the rpm.log file is empty

8) rmmod nvidia
   remove nvidia line from /etc/modules.conf

9) reboot into text mode

10) log in as root

11) run lsmod > lsmod.log so that you can check which modules are loaded

12) startx

I still see the same errors. X11 seems to be starting without errors. As soon as
the video card switches to graphical mode, the monitor gets into "economy mode".
Comment 17 Dimitri Papadopoulos 2003-09-09 09:35:18 EDT
Created attachment 94325 [details]
Comment 18 Dimitri Papadopoulos 2003-09-09 09:36:57 EDT
Created attachment 94326 [details]
lsmod > lsmod.log
Comment 19 Mike A. Harris 2003-09-09 09:59:44 EDT
Ok, thanks.  Your card is detected by the XFree86 nv driver ok:

(--) PCI:*(1:0:0) nVidia Corporation NV18GL [Quadro4 NVS] rev 162, Mem @
0xfc000000/24, 0xf0000000/27, BIOS @ 0xc1000000/17
(--) Chipset Quadro4 280 NVS found

There is nothing else significant that I can see in the log file.  Your
video card is getting correctly detected by the installer and configured
properly for the XFree86 open source driver, so the summary line of the
bug report is rather incorrect.

It does appear however that DDC probing both via ddcprobe and inside
the driver are not yeilding results.  Investigating...

Comment 20 Mike A. Harris 2003-09-09 10:20:47 EDT
I just realized that your display is a flat panel, and not a CRT.  The "nv"
driver does not "officially" support flat panel displays in 4.3.0.  It contains
only experimental DFP support, which is supplied as-is in hopes it works
for people.  Any problems encountered while using the "nv" driver with
flat panel displays should be reported to XFree86.org directly, by posting
a bug report at:  http://bugs.xfree86.org  and attaching the config file
and log file similarly to that report.

Before filing a bug report upstream, you should test the XFree86 developmental
"nv" driver, as the DFP support has been greatly enhanced in the current
CVS tree compared to 4.3.0.

Comment 21 Mike A. Harris 2003-09-09 10:21:10 EDT

*** This bug has been marked as a duplicate of 67193 ***
Comment 22 Dimitri Papadopoulos 2003-09-09 13:12:36 EDT
As far as I'm concerned, it's not a problem if the 'nv' driver doesn't support
the monitor, since I'll be switching to 'nvidia' drivers during post-install.
It's just that post-install is much easier when the monitor has been probed and
the XF86Config "Monitor" section updated accordingly.

For the sake of completeness, here is the output of dccprobe on this machine
(the 'nvidia' drivers are used instead of 'nv' here):

# /usr/sbin/ddcprobe

Videocard DDC probe results
Description:  NVIDIA Corporation NV18 Board - p118wsnz
Memory (MB):  64

Monitor DDC probe results
Monitor DDC Probe failed.

Do not hesitate to ask for more information if needed.
Comment 23 Red Hat Bugzilla 2006-02-21 13:58:30 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.