Bug 67193 - The 'nv' driver shipped with Red Hat Linux doesn't support DFP display types.
The 'nv' driver shipped with Red Hat Linux doesn't support DFP display types.
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: Xconfigurator (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
: 70646 103955 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-06-20 15:18 EDT by Everett Lipman
Modified: 2007-04-18 12:43 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-06-20 15:18:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Everett Lipman 2002-06-20 15:18:03 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.75 [en] (X11; U; SunOS 5.7 sun4u)

Description of problem:
Xconfigurator recognizes my Nvidia GEForce 3 card, but fails to
mention that the DVI flat panel interface is not supported by
the driver.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Purchase Dell computer with NVidia card.
2.Try to install RedHat 7.3 with monitor connected via DVI.
3.Bang head against wall trying to figure out why X won't work
  even though everything looked ok during installation.
	

Actual Results:  I experienced severe frustration until I (fortunately) finally
found an email on some mailing list bulletin board from a
developer at NVidia telling another user that the nv driver
doesn't support DVI.

Expected Results:  Xconfigurator (or at least some documentation) should have
warned
me that the support for my card is not complete.  Ideally it would
suggest that I use the analog interface or get the driver from
NVidia.  I realize the pointer to the other driver is a bit much
to ask, since RH must support billions of cards.


Additional info:
Comment 1 Mike A. Harris 2002-06-23 08:31:52 EDT
Unfortunately, there is no way for _us_ to know wether or not a given
driver supports DVI or any other feature for that matter.  In order to know
what features are supported by each piece of hardware, we would need to
have every piece of hardware, and then go through the X source code completely
every release to determine what features are available both in the hardware,
and wether or not they are supported, and then actually test each feature
to ensure it works.

While that would be nice, it just is not feasible.  There is no feasible
way for us to provide users with this information ahead of time.

The best way to know if something is supported, is to ask on
xpert@xfree86.org, and to search the Internet.

Sorry for any inconveniences you may have been caused by this.  Hopefully
in the future, video hardware manufacturers will more directly support
Linux and will write drivers which support all of the features of their
hardware.
Comment 2 Mike A. Harris 2002-08-03 13:52:28 EDT
*** Bug 70646 has been marked as a duplicate of this bug. ***
Comment 3 Everett Lipman 2002-08-03 16:50:16 EDT
Looks like NVidia DVI support will show up in XFree86 soon:

http://www.xfree86.org/pipermail/xpert/2002-May/017380.html
http://www.xfree86.org/pipermail/xpert/2002-May/017549.html
Comment 4 Mike A. Harris 2003-09-09 10:21:13 EDT
*** Bug 103955 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.