This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 102892 - RFE: Please add the following Dell displays to the MonitorsDB
RFE: Please add the following Dell displays to the MonitorsDB
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: hwdata (Show other bugs)
9
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
http://support.ap.dell.com/docs/monit...
:
: 102893 (view as bug list)
Depends On:
Blocks: CambridgeBlocker 101028
  Show dependency treegraph
 
Reported: 2003-08-22 09:28 EDT by Dimitri Papadopoulos
Modified: 2014-03-16 22:38 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-20 09:58:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
output of /sbin/lspci -v (4.86 KB, text/plain)
2003-08-22 09:30 EDT, Dimitri Papadopoulos
no flags Details
output of /sbin/lspci -vn (3.67 KB, text/plain)
2003-08-22 09:31 EDT, Dimitri Papadopoulos
no flags Details
.inf file for Dell 1900FP (2.35 KB, text/plain)
2003-08-25 04:33 EDT, Dimitri Papadopoulos
no flags Details
.inf file for Dell P1130 (1.84 KB, text/plain)
2003-08-25 04:52 EDT, Dimitri Papadopoulos
no flags Details
.inf file for Dell 1702FP (2.35 KB, text/plain)
2003-08-25 05:17 EDT, Dimitri Papadopoulos
no flags Details
.inf file for Dell 2000FP (2.22 KB, text/plain)
2003-08-25 05:18 EDT, Dimitri Papadopoulos
no flags Details
.inf file for Dell E772c (1.94 KB, text/plain)
2003-08-25 05:22 EDT, Dimitri Papadopoulos
no flags Details
.inf file for Dell E151FPb (1.86 KB, text/plain)
2003-08-25 06:56 EDT, Dimitri Papadopoulos
no flags Details
.inf file for Dell E773c (1.92 KB, text/plain)
2003-08-25 07:00 EDT, Dimitri Papadopoulos
no flags Details
.inf file for Dell 1703FP (2.35 KB, text/plain)
2003-08-25 07:01 EDT, Dimitri Papadopoulos
no flags Details
.inf file for Dell 1901FP (2.35 KB, text/plain)
2003-08-25 07:03 EDT, Dimitri Papadopoulos
no flags Details
.inf file for Dell E551c (1.89 KB, text/plain)
2003-08-25 07:05 EDT, Dimitri Papadopoulos
no flags Details
.inf file for Dell E771mm (1.88 KB, text/plain)
2003-08-25 07:09 EDT, Dimitri Papadopoulos
no flags Details
.inf file for Dell E771a (1.91 KB, text/plain)
2003-08-25 07:24 EDT, Dimitri Papadopoulos
no flags Details
.inf file for Dell P793 (1.82 KB, text/plain)
2003-08-25 07:26 EDT, Dimitri Papadopoulos
no flags Details

  None (edit)
Description Dimitri Papadopoulos 2003-08-22 09:28:29 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030624

Description of problem:
Hi,

When kickstart-installing Red Hat Linux 9 on a Dell Precision 530, the Dell
1900FP 19" LCD display is not recognized and suboptimal standard frequency
ranges are used instead of:
H 30 - 80 kHz
V 56 - 76 Hz


Version-Release number of selected component (if applicable):
4.3.0-2

How reproducible:
Always

Steps to Reproduce:
1. Install Red Hat Linux 9


Actual Results:  The installer says "Monitor not recognized" and configures
XFree86 with suboptimal frequency ranges.


Expected Results:  The installer should recognize the monitor and configure
XFree86 with proper frequency ranges.


Additional info:
Comment 1 Dimitri Papadopoulos 2003-08-22 09:30:23 EDT
Created attachment 93854 [details]
output of /sbin/lspci -v
Comment 2 Dimitri Papadopoulos 2003-08-22 09:31:59 EDT
Created attachment 93855 [details]
output of /sbin/lspci -vn
Comment 3 Mike A. Harris 2003-08-22 13:20:51 EDT
lspci shows PCI devices only.  A monitor is not a PCI device, so it won't
show up in lspci.

In order to add the monitor(s) to the database, I need you to attach the
Windows .INF file for theses monitors to the bug report as a file attachment,
so I can automate their addition to the database as a whole.

Thanks in advance.
Comment 4 Mike A. Harris 2003-08-22 13:23:17 EDT
*** Bug 102893 has been marked as a duplicate of this bug. ***
Comment 5 Dimitri Papadopoulos 2003-08-25 04:33:25 EDT
Created attachment 93889 [details]
.inf file for Dell 1900FP
Comment 6 Dimitri Papadopoulos 2003-08-25 04:34:28 EDT
I've sent the output of lspci because I had been asked for it in bug #53364:
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=53364

Please find attached an .INF file for the 1900FP monitor, I've found it on a Web
site.

I couldn't find any such file for P1130, I'll try to find it on the CDs we got
from Dell, if we still have them.
Comment 7 Dimitri Papadopoulos 2003-08-25 04:52:57 EDT
Created attachment 93890 [details]
.inf file for Dell P1130
Comment 8 Dimitri Papadopoulos 2003-08-25 04:53:43 EDT
Please find attached an .INF file for the P1130 monitor, I've found it on the
Dell Web site.
Comment 9 Dimitri Papadopoulos 2003-08-25 05:16:37 EDT
Note that drivers for Dell monitors can be found here:
http://ftp.dell.com/monitors/

There are some recent drivers over there, you may want to donwload and add them
to the database. Anyway, I'm attaching the .inf files for most recent ones.

It would be nice if the database could be updated automatically from such sites
(maybe at installation time so that monitors released after the Red Hat
distribution can still be recognized).
Comment 10 Dimitri Papadopoulos 2003-08-25 05:17:35 EDT
Created attachment 93892 [details]
.inf file for Dell 1702FP
Comment 11 Dimitri Papadopoulos 2003-08-25 05:18:27 EDT
Created attachment 93893 [details]
.inf file for Dell 2000FP
Comment 12 Dimitri Papadopoulos 2003-08-25 05:22:22 EDT
Created attachment 93894 [details]
.inf file for Dell E772c
Comment 13 Dimitri Papadopoulos 2003-08-25 06:56:29 EDT
Created attachment 93898 [details]
.inf file for Dell E151FPb
Comment 14 Dimitri Papadopoulos 2003-08-25 07:00:14 EDT
Created attachment 93899 [details]
.inf file for Dell E773c
Comment 15 Dimitri Papadopoulos 2003-08-25 07:01:37 EDT
Created attachment 93900 [details]
.inf file for Dell 1703FP
Comment 16 Dimitri Papadopoulos 2003-08-25 07:03:32 EDT
Created attachment 93901 [details]
.inf file for Dell 1901FP
Comment 17 Dimitri Papadopoulos 2003-08-25 07:05:17 EDT
Created attachment 93902 [details]
.inf file for Dell E551c
Comment 18 Dimitri Papadopoulos 2003-08-25 07:09:49 EDT
Created attachment 93903 [details]
.inf file for Dell E771mm
Comment 19 Dimitri Papadopoulos 2003-08-25 07:24:16 EDT
Created attachment 93904 [details]
.inf file for Dell E771a
Comment 20 Dimitri Papadopoulos 2003-08-25 07:26:22 EDT
Created attachment 93905 [details]
.inf file for Dell P793
Comment 21 Dimitri Papadopoulos 2003-08-28 09:56:41 EDT
I couldn't find any .inf file for the Dell Latitude C800 laptop. Would it be
possible to exceptionally update the XFree86 database from the specs:
http://docs.us.dell.com/docs/systems/latc800/en/ug/specs.htm#14-inch_display

Red Hat 7.3 used to install properly on this laptop as far as I can remember,
but Red Hat 9 does not. It doesn't recognize the display.
Comment 22 Mike A. Harris 2003-09-09 10:24:57 EDT
The reason your display is not detected is because you're using an Nvidia
video adaptor and a flat panel LCD display, however the "nv" driver does not
support DFP displays officially.  It contains initial experimental support only,
and is not considered supported.  A future version of XFree86 will support
DFP on Nvidia much better.

01:00.0 VGA compatible controller: nVidia Corporation NV25GL [Quadro4 700 XGL]
(rev a3) (prog-if 00 [VGA])

That said, I definitely can add the various monitors you've been kind enough
to attach to the bug report, into our Monitors database.  Thanks for taking
the time to track down all of the files and attach them.
Comment 23 Dimitri Papadopoulos 2003-09-09 12:44:34 EDT
Oh, then I guess most of these monitors are already in the database - such as
1702FP. They're not detected because most of them are flat and thus unsupported
by the 'nv' XFree86 driver.

Note that some entries are (very slightly) wrong though. For example this:

Dell; Dell 1702FP (Analog); DEL3007; 30.0-80.0; 56.0-76.0; 1
Dell; Dell 1702FP (Digital); DEL3006; 30.0-80.0; 56.0-76.0; 1

should be changed to:

Dell; Dell 1702FP (Analog); DEL3007; 31.0-80.0; 56.0-76.0; 1
Dell; Dell 1702FP (Digital); DEL3006; 31.0-80.0; 56.0-76.0; 1

according to the specs:

http://support.ap.dell.com/docs/monitors/1702fp/en/specs.htm

But then the .inf file itself is wrong! Oh well...
Comment 25 Mike A. Harris 2004-02-20 09:58:17 EST
Ok, I've confirmed that these monitors are indeed listed in the
MonitorsDB as indicated above.  I disagree that the entries should
be changed to what is on Dell's website however for several reasons.

- The monitor's own built in DDC probed information will be used on
hardware that is DDC compatible with drivers that are DDC compatible
which will override anything in the database anyway.

- The Windows .INF files are what will be used in Microsoft Windows,
and any error in the .INF file that causes problems in Windows
would most likely be corrected by Dell immediately if it caused
any problems for customers.

- The webpage itself is not the authoritative source of technical
information for the hardware.

I consider the DDC probed information to be considered the best
source of information, and the Window's .INF files secondary. If
DDC is for some reason unreliable and the .INF file data must be
used, as long as the .INF file data results in a working display
with no problems, then that is the best data to stick with.

If however someone has an actual bug caused by the .INF file data,
we can certainly investigate their matter and possibly change
our database, however I prefer to stick with manufacturer supplied
data from .INF files in lieu of an actual bug being found.

Closing as 'RAWHIDE' as the monitor database is up to date for these
displays as indicated above.

Note You need to log in before you can comment on or make changes to this bug.