This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 103971 - /etc/init.d/bluetooth errors
/etc/init.d/bluetooth errors
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: kernel (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On: 88859
Blocks: CambridgeTarget
  Show dependency treegraph
 
Reported: 2003-09-08 12:55 EDT by Chris Ricker
Modified: 2007-04-18 12:57 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-09-11 17:30:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Chris Ricker 2003-09-08 12:55:50 EDT
I get the following error when booting up, and also when upgrading from

bluez-utils-2.3-9

to

bluez-utils-2.3-12:

Can't open RFCOMM control socket: No such file or directory


It's coming from this part of the init script:

        if [ -x /usr/bin/rfcomm -a -f /etc/bluetooth/rfcomm.conf ]; then
                /usr/bin/rfcomm -f /etc/bluetooth/rfcomm.conf bind all
        fi

That appears to require a socket which isn't present on my system (probably b/c
I don't have bluetooth hardware)

I also see the following in dmesg once this error occurs:

request_module[bt-proto-3]: fork failed, errno 1
Comment 1 David Woodhouse 2003-09-08 19:18:54 EDT
Well for cosmetic reasons I suppose the rfcomm tool could refrain from actually
opening its socket unless it needs to, but the modprobe shouldn't fail and there
shouldn't be any errors.

Bug #88859 seems to have recurred, but that isn't the problem in this case. It
looks like the kernel isn't even managing to run modprobe. Does it manage to
autoload any other modules?

Reassigning to kernel.
Comment 2 Chris Ricker 2003-09-09 09:28:49 EDT
It autoloads other modules just fine....
Comment 3 Chris Ricker 2003-09-11 17:29:48 EDT
I don't see this any more with kernel-2.4.22-1.2040.nptl from RHN

Note You need to log in before you can comment on or make changes to this bug.