Bug 88859 - Aliases for BlueZ kernel modules missing
Aliases for BlueZ kernel modules missing
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: modutils (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brian Brock
http://cvs.sourceforge.net/cgi-bin/vi...
:
: 89649 (view as bug list)
Depends On:
Blocks: 103971
  Show dependency treegraph
 
Reported: 2003-04-14 21:15 EDT by James Clark
Modified: 2014-03-16 22:35 EDT (History)
3 users (show)

See Also:
Fixed In Version: 2.4.25-9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-09-08 19:27:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Clark 2003-04-14 21:15:11 EDT
modutils doesn't know about the BlueZ kernel modules, which means that bluetooth
won't work unless the user manually adds stuff to their modules.conf.  alias.h
needs the following added (this list comes from linked URL):

	alias net-pf-31		bluez
	alias bt-proto-0	l2cap
	alias bt-proto-2	sco
	alias bt-proto-3	rfcomm
	alias bt-proto-4	bnep
	alias tty-ldisc-15	hci_uart
	alias char-major-216	rfcomm
	alias char-major-10-250	hci_vhci
Comment 1 Bill Nottingham 2003-04-25 19:07:03 EDT
*** Bug 89649 has been marked as a duplicate of this bug. ***
Comment 2 Bill Nottingham 2003-04-25 19:07:24 EDT
fixed in 2.4.25-1.
Comment 3 David Woodhouse 2003-09-08 19:16:50 EDT
imladris /root # rpm -qi modutils
Name        : modutils                     Relocations: (not relocateable)
Version     : 2.4.25                            Vendor: Red Hat, Inc.
Release     : 8                             Build Date: Mon 07 Jul 2003 22:08:16 BST
Install Date: Sat 30 Aug 2003 19:46:37 BST      Build Host: bugs.devel.redhat.com
Group       : System Environment/Kernel     Source RPM: modutils-2.4.25-8.src.rpm
Size        : 584540                           License: GPL
Signature   : DSA/SHA1, Wed 16 Jul 2003 21:07:33 BST, Key ID fd372689897da07a
Packager    : Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla>
Summary     : Kernel module management utilities.
Description :
The modutils package includes various programs needed for automatic
loading and unloading of modules under 2.2 and later kernels, as well
as other module management programs. Device drivers and filesystems
are two examples of loaded and unloaded modules.
imladris /root # rpm -V modutils
imladris /root # /sbin/modprobe -c | grep bt-proto
imladris /root # modprobe bt-proto-2
modprobe: Can't locate module bt-proto-2
imladris /root # modprobe sco
imladris /root #

Comment 4 Bill Nottingham 2003-09-08 19:27:23 EDT
Argh, typo. Fixed in -9.

Note You need to log in before you can comment on or make changes to this bug.