Bug 104564 - gdm beeps
gdm beeps
Status: CLOSED WORKSFORME
Product: Red Hat Raw Hide
Classification: Retired
Component: gdm (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
Mike McLean
: Triaged
: 113258 (view as bug list)
Depends On:
Blocks: CambridgeTarget
  Show dependency treegraph
 
Reported: 2003-09-17 05:47 EDT by Tim Waugh
Modified: 2007-04-18 12:57 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-24 15:10:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch for making the login beep configurable. (5.76 KB, patch)
2003-11-10 20:26 EST, Kai Thomsen
no flags Details | Diff

  None (edit)
Description Tim Waugh 2003-09-17 05:47:15 EDT
Description of problem:
When gdm presents me with the login screen I get a beep.

Version-Release number of selected component (if applicable):
gdm-2.4.4.0-2

How reproducible:
100%

Happens on a fresh install.
Comment 1 Alexander Larsson 2003-10-06 10:25:34 EDT
I thougth this was supposed to happen. (so blind users know when to login, etc.)
Maybe we don't really want it though.
Comment 2 Gérard Milmeister 2003-11-07 05:31:05 EST
On Fedora Core 1, gdm-2.4.4.5-1, this happens too
Comment 3 Gérard Milmeister 2003-11-07 06:41:36 EST
Sorry, I didn't read the previous comment.
Maybe the could be an option in gdm.conf to
set the beep, or a .wav to play.
Comment 4 Kai Thomsen 2003-11-10 20:24:08 EST
Here's a small patch to gdm-2.4.4.5-1 which solely fulfils the 
purpose of making the beep on login configurable (no fancy sound 
samples etc.).

It introduces a new option called "BeepOnPrompt" in the "[greeter]" 
section of /etc/X11/gdm/gdm.conf, which defaults to "yes" when 
omitted or commented out.  The option is not integrated in the 
graphical configuration tool "gdmsetup", though.
Comment 5 Kai Thomsen 2003-11-10 20:26:13 EST
Created attachment 95892 [details]
Patch for making the login beep configurable.
Comment 6 Aleksey Nogin 2004-01-19 00:28:00 EST
*** Bug 113258 has been marked as a duplicate of this bug. ***
Comment 7 Kai Thomsen 2004-01-19 11:58:22 EST
Sound support is configurable as of gdm-2.5.90.0 (see GNOME Bugzilla: 
http://bugzilla.gnome.org/show_bug.cgi?id=125487).
Comment 8 Peter Fales 2004-02-16 13:18:47 EST
Another vote for getting rid of this beep (or making it a
configuration choice).   The beep is quite loud and annoying on my IBM
Thinkpad T21 
Comment 9 Matthew Miller 2004-07-24 15:10:44 EDT
This *is* a configuration choice -- check the Accessability tab of the
GDM configuration tool (aka System Settings -> Login Screen). You can
turn it off, or make it a different sound. Possible the default should
be something prettier than a beep (which sounds like an error) -- but
that's a different issue.
Comment 10 Peter Fales 2004-07-25 00:25:20 EDT
For the record, and for those who run different desktops, you can 
run gdmsetup to start this gui directly.   Or, you can directly edit
/etc/X11/gdm/gdm.conf and change 

#SoundOnLogin=true
to
SoundOnLogin=false


Note You need to log in before you can comment on or make changes to this bug.