Bug 105009 - oprofile does not make use of debuginfo
oprofile does not make use of debuginfo
Status: CLOSED RAWHIDE
Product: Red Hat Linux Beta
Classification: Retired
Component: oprofile (Show other bugs)
RC3
All Linux
medium Severity medium
: ---
: ---
Assigned To: William Cohen
:
: 105355 (view as bug list)
Depends On:
Blocks: CambridgeTarget
  Show dependency treegraph
 
Reported: 2003-09-24 12:00 EDT by William Cohen
Modified: 2007-04-18 12:57 EDT (History)
0 users

See Also:
Fixed In Version: 0.7cvs-0.20030829.6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-30 10:02:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description William Cohen 2003-09-24 12:00:19 EDT
Description of problem:

oprofile does not make use of the debuginfo information.


Version-Release number of selected component (if applicable):

oprofile-0.7cvs-0.20030917.1

How reproducible:

always


Steps to Reproduce:
1. Install oprofile-0.7cvs-0.20030917.1 and associated debuginfo rpm on a x86
machine with an smp kernel.

2. as root setup up oprofile to collect data
     opcontrol --setup --vmlinux=/boot/vmlinux-`uname -r`
     opcontrol --start
     # run some stuff to get samples
     opcontrol --shutdown
     
3. verify there are sample
     opreport image:/usr/bin/oprofiled

   however the following doesn't show samples

     opreport image:/usr/bin/oprofiled -l

    
Actual results:

opreport image:/usr/bin/oprofiled -l
CPU: PII, speed 232.675 MHz (estimated)
Counted CPU_CLK_UNHALTED events (clocks processor is not halted) with a unit
mask of 0x00 (No unit mask) count 116337
samples  %           symbol name
260      100.0000    (no symbols)

Expected results:

Detailed listing show samples on a pre-function basis.

Additional info:
Comment 1 William Cohen 2003-09-24 12:53:38 EDT
separatedebug patch not in this rpm. It needs to be revised to apply.
Comment 2 William Cohen 2003-10-01 16:52:46 EDT
*** Bug 105355 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.