Bug 105355 - oprofile does not make use of debuginfo
Summary: oprofile does not make use of debuginfo
Status: CLOSED DUPLICATE of bug 105009
Alias: None
Product: Red Hat Linux Beta
Classification: Retired
Component: oprofile   
(Show other bugs)
Version: RC3
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Lawrence
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: CambridgeTarget
TreeView+ depends on / blocked
 
Reported: 2003-09-25 13:05 UTC by William Cohen
Modified: 2007-04-18 16:57 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 18:58:44 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description William Cohen 2003-09-25 13:05:22 UTC
Description of problem:

oprofile does not make use of the debuginfo information.


Version-Release number of selected component (if applicable):

oprofile-0.7cvs-0.20030917.1

How reproducible:

always


Steps to Reproduce:
1. Install oprofile-0.7cvs-0.20030917.1 and associated debuginfo rpm on a x86
machine with an smp kernel.

2. as root setup up oprofile to collect data
     opcontrol --setup --vmlinux=/boot/vmlinux-`uname -r`
     opcontrol --start
     # run some stuff to get samples
     opcontrol --shutdown
     
3. verify there are sample
     opreport image:/usr/bin/oprofiled

   however the following doesn't show samples

     opreport image:/usr/bin/oprofiled -l

    
Actual results:

opreport image:/usr/bin/oprofiled -l
CPU: PII, speed 232.675 MHz (estimated)
Counted CPU_CLK_UNHALTED events (clocks processor is not halted) with a unit
mask of 0x00 (No unit mask) count 116337
samples  %           symbol name
260      100.0000    (no symbols)

Expected results:

Detailed listing show samples on a pre-function basis.

Additional info:

Comment 1 William Cohen 2003-10-01 20:52:41 UTC

*** This bug has been marked as a duplicate of 105009 ***

Comment 2 Red Hat Bugzilla 2006-02-21 18:58:44 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.