This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 105015 - kernel-2.6.0-0.test5.1.43 has bad prerequisite on module-init-tools
kernel-2.6.0-0.test5.1.43 has bad prerequisite on module-init-tools
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: kernel (Show other bugs)
1.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brian Brock
http://people.redhat.com/arjanv/2.5/R...
:
: 105328 (view as bug list)
Depends On:
Blocks: 105050
  Show dependency treegraph
 
Reported: 2003-09-24 13:39 EDT by Hans Ecke
Modified: 2014-03-16 22:38 EDT (History)
5 users (show)

See Also:
Fixed In Version: 2.4.25-10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-13 15:32:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Hans Ecke 2003-09-24 13:39:30 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5b) Gecko/20030917
Firebird/0.6.1+

Description of problem:
Trying to install kernel-2.6.0-0.test5.1.43.i686.rpm from the above URL, I get
this message:
error: Failed dependencies:
        module-init-tools is needed by kernel-2.6.0-0.test5.1.43

This is wrong: the newest modutils (2.4.25-9 right now) already include a copy
of module-init-tools. Instead, the kernel should have a dependency on
modutils>=2.4.22-9: according to the changelog, thats when support for 2.5/2.6
kernels was added.

Version-Release number of selected component (if applicable):
kernel-2.6.0-0.test5.1.43

How reproducible:
Always

Steps to Reproduce:
1.Install the latest modutils etc
2.rpm -ivh kernel-2.6.0-0.test5.1.43.i686.rpm
3.
    

Actual Results:  rpm outputs:

warning: kernel-2.6.0-0.test5.1.43.i686.rpm: V3 DSA signature: NOKEY, key ID
9d6b4012
error: Failed dependencies:
        module-init-tools is needed by kernel-2.6.0-0.test5.1.43


Expected Results:  the kernel should install

Additional info:
Comment 1 Arjan van de Ven 2003-09-24 14:27:48 EDT
this is a bit of a glitch; we're going to make modutils-with-module-init-tools
also Provide: module-init-tools, but due to my mistake that package isn't built
in rawhide yet...
Comment 2 Bill Nottingham 2003-09-24 23:13:05 EDT
*** Bug 105328 has been marked as a duplicate of this bug. ***
Comment 3 Barry K. Nathan 2003-10-12 15:00:29 EDT
This bug doesn't seem to happen anymore (for me anyway). Should it be closed?
Comment 4 Bill Nottingham 2003-10-13 15:32:22 EDT
Fixed in modutils-2.4.25-10.

Note You need to log in before you can comment on or make changes to this bug.