Bug 1051388 - [RFE] Do not disable actions in VM context menu if multiple VMs are selected
Summary: [RFE] Do not disable actions in VM context menu if multiple VMs are selected
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 3.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ovirt-3.6.0-rc
: 3.6.0
Assignee: Tal Nisan
QA Contact: Shira Maximov
URL:
Whiteboard:
: 1012101 (view as bug list)
Depends On: 1217446 1218172 1218527 1218541 1295728
Blocks: 1213937 1241589
TreeView+ depends on / blocked
 
Reported: 2014-01-10 08:23 UTC by Petr Spacek
Modified: 2016-03-09 20:42 UTC (History)
15 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-03-09 20:42:10 UTC
oVirt Team: Virt
sherold: Triaged+


Attachments (Terms of Use)
webadmin-vm-context-menu.png (52.86 KB, image/png)
2014-01-10 08:23 UTC, Petr Spacek
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:0376 normal SHIPPED_LIVE Red Hat Enterprise Virtualization Manager 3.6.0 2016-03-10 01:20:52 UTC
oVirt gerrit 38415 master MERGED webadmin: Allow actions on a VM list even if not available on all VMs Never

Description Petr Spacek 2014-01-10 08:23:55 UTC
Created attachment 848095 [details]
webadmin-vm-context-menu.png

Please see attachment webadmin-vm-context-menu.png. It shows VM list where multiple VMs are selected, some of them are running and some of them are stopped.

In this case, the context menu does not allow to shutdown selected running VMs at once because the selection contains VMs which are not running. I have to select first set of running VMs, then click to shutdown and then repeat the same action for the other set of running VMs.

It would be more comfortable if the context menu allowed to issue Shutdown command even if the selected set contains VMs which are not running. Shutdown on s VM which is not running is basically no-op, right? This applies to Suspend/Poweroff/Console/Migrate.

The same applies in the other way - "Run" on the running machine is basically no-op, right? So Run/Run Once could work if the selected set contains stopped VMs mixed with running VMs.

Please let me know if it is not clear what I mean :-) Have a nice day!

Comment 2 Michal Skrivanek 2014-07-01 09:39:03 UTC
I think this is one of the few remaining basic issues in UI (the other being missing actions in VM subtab in host view)
should be easy for most of them, however people asked for mass edit VM before and that's quite more complicated. So let's not consider all of them

Then we still have 2 possibilities

1) introduce an "initial state" and apply only if it matches
  takes care of Powering up and other intermediate states which we would need to enumerate carefully if we consider "end state" instead
2) fire it into commands queue and let it fail asynchronously
  this is going to happen anyway for 1) when the state changes in the meantime, but here it will be much more

1) seems more user friendly, 2) might be easier to implement


The actions which should be simple enough:
Run, Suspend, Shutdown, Power Off, Reboot, Migrate, Cancel Migration

These probably make sense but have another selection dialog when clicked, would need some more work: Export, Assign Tags, Console Options
well, and then ultimately Edit VM
I'd leave these for another time as it may become too complex...

@Petr - note Console is already a "mass command"

Comment 3 Michal Skrivanek 2014-08-25 07:55:15 UTC
*** Bug 1012101 has been marked as a duplicate of this bug. ***

Comment 4 Scott Herold 2015-02-05 14:48:21 UTC
Let's target option 2 and target this item for a 3.6 hackathon

Comment 9 errata-xmlrpc 2016-03-09 20:42:10 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0376.html


Note You need to log in before you can comment on or make changes to this bug.