Bug 105811 - Installer crashes in confirmupgrade step
Summary: Installer crashes in confirmupgrade step
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: rawhide
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Mike McLean
URL:
Whiteboard:
: 105883 106851 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-09-27 23:47 UTC by Nicholas Miell
Modified: 2007-11-30 22:10 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-11-04 21:57:40 UTC


Attachments (Terms of Use)
anaconda crash dump (540.61 KB, text/plain)
2003-09-27 23:49 UTC, Nicholas Miell
no flags Details

Description Nicholas Miell 2003-09-27 23:47:35 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:1.5a) Gecko/20030801
Mozilla Firebird/0.6.1

Description of problem:
In short:

Traceback (most recent call last):
  File "/usr/bin/anaconda", line 1106, in ?
    intf.run(id, dispatch, configFileData)
  File "/usr/src/build/309579-i386/install//usr/lib/anaconda/text.py", line 451,
in run
TypeError: __call__() takes exactly 2 arguments (4 given)

Full debug log is attached

How reproducible:
Always

Steps to Reproduce:
Boot (using boot.iso, if that matters.), answer the questions, and then wait
while it's building the list of packages to install/resolving dependencies/etc.

Comment 1 Nicholas Miell 2003-09-27 23:49:18 UTC
Created attachment 94788 [details]
anaconda crash dump

Comment 2 Jeremy Katz 2003-09-28 05:29:02 UTC
Fixed in CVS

Comment 3 Jeremy Katz 2003-09-29 21:23:10 UTC
*** Bug 105883 has been marked as a duplicate of this bug. ***

Comment 4 Jeremy Katz 2003-10-13 22:35:00 UTC
*** Bug 106851 has been marked as a duplicate of this bug. ***

Comment 5 Nicholas Miell 2003-11-04 21:57:40 UTC
Just noticed this was still open.

The current installer works fine.


Note You need to log in before you can comment on or make changes to this bug.