Bug 105846 - kernel-utils requires() "libsnmp.so" instead of "libnetsnmp.so".
kernel-utils requires() "libsnmp.so" instead of "libnetsnmp.so".
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel-utils (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks: CambridgeTarget
  Show dependency treegraph
 
Reported: 2003-09-28 07:46 EDT by Terje Bless
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-30 22:11:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Terje Bless 2003-09-28 07:46:00 EDT
The kernel-utils package requires(libsnmp.so.5). This is from the "UCD-SNMP
compatibility mode" of NET-SNMP and is required because kernel-utils'
"cpqarrayd" links against "libsnmp.so.5" instead of "libnetsnmp.so.5".

Since UCD-SNMP is no more and this causes conflicts whith third-party packages
(upstream RPMs for e.g. RHL9) it would be a good idea to link "cpqarrayd"
against "libnetsnmp.so.5" instead of "libsnmp.so.5".

The problem may be alleviated by Bug #100489.


This of course goes for anything depending on UCD-SNMP compatibility, but
kernel-utils and hpoj (will be filed as separate bug) were the only ones I found
(`rpm -qa --requires | fgrep libsnmp.so` on an "Everything" install) that had
this problem.
Comment 1 Terje Bless 2003-09-28 07:51:23 EDT
Same problem for hpoj logged as Bug #105847.
Comment 2 Terje Bless 2004-08-30 22:11:48 EDT
Since "cpqarrayd" is no longer part of "kernel-utils" (as of Arjan's
change at Fri Jul 04 2003; tested in current Fedora Rawhide), and
kernel-utils no longer Requires(libsnmp.so.5), this is RESOLVED FIXED.

Note You need to log in before you can comment on or make changes to this bug.