Bug 105847 - hpoj requires() "libsnmp.so" instead of "libnetsnmp.so".
hpoj requires() "libsnmp.so" instead of "libnetsnmp.so".
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: hpoj (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks: CambridgeTarget
  Show dependency treegraph
 
Reported: 2003-09-28 07:50 EDT by Terje Bless
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version: 0.90-18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-09-30 03:15:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Terje Bless 2003-09-28 07:50:15 EDT
The hpoj package requires(libsnmp.so.5). This is from the "UCD-SNMP
compatibility mode" of NET-SNMP and is required because hpoj links against
"libsnmp.so.5" instead of "libnetsnmp.so.5".

Since UCD-SNMP is no more and this causes conflicts whith third-party packages
(upstream net-snmp RPMs for e.g. RHL9) it would be a good idea to link hpoj
against "libnetsnmp.so.5" instead of "libsnmp.so.5".

The problem may be alleviated by Bug #100489.


This of course goes for anything depending on UCD-SNMP compatibility, but
kernel-utils (Bug #105846) and hpoj were the only ones I found
(`rpm -qa --requires | fgrep libsnmp.so` on an "Everything" install) that had
this problem.
Comment 1 Terje Bless 2003-09-28 07:53:28 EDT
And that's what you get for cut&paste-ing... *sigh*

*This* problem will of course _not_ be alleviated in any way by Bug #100489.
That's only the same issue for the kernel-utils package in Bug #105846.
Comment 2 Tim Waugh 2003-09-29 09:07:34 EDT
Will be fixed in the next hpoj build.

Note You need to log in before you can comment on or make changes to this bug.