Bug 105893 - /etc/ntp/data directory does not exist
Summary: /etc/ntp/data directory does not exist
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: dhcp   
(Show other bugs)
Version: rawhide
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
: 106374 (view as bug list)
Depends On:
Blocks: CambridgeTarget
TreeView+ depends on / blocked
 
Reported: 2003-09-29 02:45 UTC by Steve Rodgers
Modified: 2007-11-30 22:10 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-08 14:12:23 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2004:566 normal SHIPPED_LIVE Updated dhcp and dhclient packages 2005-05-26 04:00:00 UTC

Description Steve Rodgers 2003-09-29 02:45:02 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030703

Description of problem:

ntpd is complaining it can't open /etc/ntp/data/drift.TEMP in
/var/log/messages:

Sep 28 14:20:22 steverod ntpd[4436]: can't open /etc/ntp/data/drift.TEMP: No
such file or directory

This is logged every hour in /var/log/messages.



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Start fedora beta 2
2.After a couple of hours, search through /var/log/messages for messages
similar to above.

    

Actual Results:  Log file has entries from ntpd as mentioned above.

Expected Results:  Ntpd should not write these log entries to /var/log/messages.

Additional info:

Comment 1 Bill Nottingham 2003-10-06 22:48:06 UTC
*** Bug 106374 has been marked as a duplicate of this bug. ***

Comment 2 Harald Hoyer 2003-10-08 11:58:50 UTC
does dhcp modify your /etc/ntp.conf?? driftfile should be 
driftfile /var/lib/ntp/drift


Comment 3 Mark H Johnson 2003-10-08 13:40:33 UTC
I guess I don't understand the question fully, but I'll provide some additional
information.

As I described in Bug 106374, the only steps performed was to...
 - install Fedora test 2
 - as part of the settings, select NTP
I don't see how dhcp has anything to do with where the ntp drift file goes. For
a cross check, I looked at /etc/dhcpd.conf on our dhcp server and the *only*
line with ntp on it is...

option ntp-servers overlord, gsde-serv1, gsde-serv2;

which IP addresses appear in /etc/ntpd.conf as part of...

# generated by /sbin/dhclient-script
restrict default ignore
restrict 127.0.0.1
driftfile /etc/ntp/data/drift
broadcastdelay 0.008
authenticate yes
keys /etc/ntp/keys
restrict 192.52.216.1 nomodify notrap noquery
server 192.52.216.1
restrict 192.52.216.4 nomodify notrap noquery
server 192.52.216.4
restrict 192.52.216.29 nomodify notrap noquery
server 192.52.216.29

But there is a clue - #created by /sbin/dhclient-script. That file has the
lines...

grep ntp /sbin/dhclient-script
  elif [ -n "$new_ntp_servers" ] && [ -e /etc/ntp.conf ]; then
      save_previous /etc/ntp.conf
      cat <<EOF > /etc/ntp.conf
driftfile /etc/ntp/data/drift
keys /etc/ntp/keys
      save_previous /etc/ntp/step-tickers
      echo '# generated by /sbin/dhclient-script' > /etc/ntp/step-tickers
      for I in $new_ntp_servers; do
          echo "restrict $I nomodify notrap noquery" >> /etc/ntp.conf
          echo "server $I" >> /etc/ntp.conf
          echo "$I" >> /etc/ntp/step-tickers

So I believe we have found the culprit. If you want it in /var - please change
the scripts that set up ntp "make it so".


Comment 4 Harald Hoyer 2003-10-08 13:54:23 UTC
changing component to dhcp

Comment 5 Daniel Walsh 2003-10-08 14:12:23 UTC
Fixed in dhcp-3_0pl2-6_16


Should be in Rawhide shortly.

Comment 6 Paul Moore 2004-08-14 17:30:03 UTC
Also occurs in RHEL 3. - problem is in the coding of
/sbin/dhclient-script in dhclient-3.0p12-6.14
A fix should be sent through up2date for RHEL systems.

Comment 7 John Flanagan 2004-12-21 19:42:11 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2004-566.html



Note You need to log in before you can comment on or make changes to this bug.