Red Hat Bugzilla – Bug 105969
aspell-it obsolete, conflicts with aspell requirement
Last modified: 2007-11-30 17:10:31 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030703
Description of problem:
The aspell package shipping since Severn1 (9.0.93) has required all the
dictionary modules to be of versions 0.50 or greater. However, the aspell-it
module is still at version 0.1-17.
This breaks apt-get; I have had to remove aspell-it as soon as I need to use
apt-get. Probably have not been noticed by many people as they would not have
all language files installed.
Version-Release number of selected component (if applicable):
Steps to Reproduce:
1. Install apt from Fedora
2. Configure apt for use with 0.94 repositories
3. Use apt-get to install something
Actual Results: The following packages have unmet dependencies:
aspell: Obsoletes: aspell-it (< 0.50) but 0.1-17 is to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a
Expected Results: apt-get works without errors
aspell-it pre 0.50 is indeed obsolete. Unfortunately, we have intentionally not
upgraded aspell-it because the copyright/license issue surrounding the original
source tarball has not been resolved.
When it is, we will upgrade aspell-it.
*** Bug 107370 has been marked as a duplicate of this bug. ***
aspell-it 0.53 should be free under the GPL now. Could you reconsider
to integrate it in the standard distribution please?