Bug 106 - Can not do a nfs/network/hard disk install with an LS-120
Can not do a nfs/network/hard disk install with an LS-120
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
5.2
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Matt Wilson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1998-11-17 11:27 EST by night
Modified: 2014-03-19 07:09 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-04-14 16:26:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description night 1998-11-17 11:27:32 EST
Trying to use an LS-120 floppy drive to install that
requires the use of the supp.img or rescue.img is
impossible becuase the install is hardcoded to use
/dev/fd0 as the floppy drive.  When using an LS-120
drive, which is connected to the IDE interface, this
would be /dev/hda1.  The install should check somehow
to see from where it is booting, and if it does not
find a /dev/fd0, then ask for the second disks device
path.  An alternative would be to pass boot time options
to the installer/kernel would could do the right thing.

Installing directly off CD (either by booting or by using
the boot floppy) works ok with only an LS-120 as a floppy
disk drive.
Comment 1 Cristian Gafton 1998-11-18 21:14:59 EST
For the time being this is "not supported"
Comment 2 timehorse 1999-01-03 23:00:59 EST
Because my Linux bootable floppy got corrupted, I can no longer access
any of my Linux partitions after my MBR got nuked.  This is very sad.

RedHat should not behaive like a certain Monopolist MBR-nuking company
in Redmond Washington and take more concern for those of us who use
LS-120 or Zip disks as our bootable media.

If it were at least possible for the user to at least specify the
drive from which to load the rescue disk at boot up, this would not be
a problem.  Maybe I should change your boot code myself to optionally
get the boot drive from a kernel parameter.  What's more, if I boot
from CDROM, it still expects to find a rescue disk on my 5 1/2" drive,
even though an image rescue disk already exists on the CD.  :(

This situation leaves me no choice but (thanks to the fact that RedHat
does NOT have a monopoly on Linux distributions) to seek out another
vender for my Linux needs.  I am very disappointed in your attitude on
this issue indeed.  :(
Comment 3 David Lawrence 1999-06-28 12:25:59 EDT
We are trying to work un an acceptable solution for upcoming releases
to handle this since it is becoming more common. Sadly it still occurs
in 6.0. I have assigned to to a developer for further review.
Comment 4 Jay Turner 1999-07-07 12:33:59 EDT
*** Bug 3196 has been marked as a duplicate of this bug. ***

I have a new Winbook XL2 notebook which has a ATAPI LS-120
Superdisk floppy (120 MB and compatible with 1.44 MB).  It
does not have a traditional floppy drive (kernel bootup msg:
"floppy0: no floppy controllers found").

It can boot off the bootnet floppy fine, but if I want to do
an install that requires a supplemental disk (e.g., network
install that requires PCMCIA devices), install will ONLY
attempt to mount /dev/fd0, never /dev/hdd, which was the
original boot device.  A simple fix would be, upon failure
to mount fd0, to ask the user to mount from a list of
detected devices.
Comment 5 Jay Turner 1999-07-07 13:13:59 EDT
*** Bug 3908 has been marked as a duplicate of this bug. ***

My computer has only LS-120 SuperDisk IDE ATAPI floppy disk
drive. When I want to make a boot diskette (when asked by
installer) installer hangs, because there is no /dev/fd0
device.

However, answering "no" to above mentioned question,
installation continues with no other problems at all.

There should be some sort of warning, that installer could
not make boot diskette on /dev/fd. Eventualy - installer
should make boot floppy on /dev/hdX

This bug can also affect other ATAPI connected floppy
drives, ZIP drives and drives, connected thru parallel port.

Hope you will find this bug report useful!
Comment 6 Bill Nottingham 1999-09-24 23:46:59 EDT
*** Bug 2205 has been marked as a duplicate of this bug. ***

hi

could you please re-enable the possibility to install to
ls120 disk4s ? (i compiled a kernel with ide-floppy support
and commented 1 line in your installer code and succeeded)

an additional change has to be made with the lilo-installer

you need the parameters
disk /dev/hdc (if the ls120 is secondary master)
   bios 0x00

in lilo.conf

and you have to install the stuff to /dev/hdc (not hdc1) ..

2) please let someone chose to dis/enable ALL packages (at
least in expert mode) to reduce the minimal install size of
redhat

see ya.



------- Additional Comments From dkl@redhat.com  05/07/99 14:15 -------
Thank you for the suggestions. It has been assigned to a developer for
further review.*** Bug 3506 has been marked as a duplicate of this bug. ***

I tried to install RH 6.0 via NFS on a system with LS120.
The kernel, that is in the bootnet.img file, does not
support ide-floppy. I solved that problem by creating a new
kernel. But with the new kernel I can access the LS120
during installation (on the second virtual console), but the
install program does not find it as /dev/hda.  It searches
for SCSI disk, does not find any and says, that my system
has no harddisk.  I have created the devices for hda1-9 by
hand, but that does not solve the problem.  How can I
install RH 6.0 on a LS120???

Further information:
I did a network installation via a PXE bios.  I took the
initrd image and the kernel from the network boot disk and
installed them on a tftp server.  The kernel was booted via
bpbatch.  RH 6.0 does not use a second floppy.  That is very
important, because the computer has no floppy and all
modules have to be in the initrd image or have to be loaded
from the NFS server.
Comment 7 Jay Turner 2000-02-10 13:03:59 EST
Have put this on a list of features for future releases.
Comment 8 Matt Wilson 2000-04-14 16:25:59 EDT
The original problem listed here is that you couldn't load the supp.img disk
with an LS210.  We no longer need supp.img, so FTP/HTTP/Hard Drive installs are
possible on a LS120 drive.

Further LS120 support will be in future versions of Red Hat Linux, but the
original problem in this bug was fixed in 6.1
Comment 9 Erik Troan 2000-06-18 13:17:15 EDT
Better LS-120 support will be available in our next release. It should use
/dev/hda during the install properly, and write out a correct fstab.

Note You need to log in before you can comment on or make changes to this bug.