Bug 106343 - Updating fedora core fails at bootloader configration update/skip/new
Updating fedora core fails at bootloader configration update/skip/new
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
: 107354 (view as bug list)
Depends On:
  Show dependency treegraph
Reported: 2003-10-06 05:33 EDT by Ossama Khayat
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2003-10-23 10:29:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Anaconda crash report (587.14 KB, text/plain)
2003-10-06 05:40 EDT, Ossama Khayat
no flags Details
Requested output from: rpm -qa --qf "%{EPOCH}:%{NAME}-%{VERSION}-%{RELEASE}\n" (13.17 KB, text/plain)
2003-10-11 14:04 EDT, Ossama Khayat
no flags Details
the error while trying to upgrade from test2 to test3 (590.29 KB, text/plain)
2003-10-23 09:35 EDT, Ossama Khayat
no flags Details

  None (edit)
Description Ossama Khayat 2003-10-06 05:33:53 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030703

Description of problem:
Trying to upgrade my system (FC test2) by using Anaconda, since
redhat-config-packages doesn't work, the installer crashes when it reaches to
the point of choosing weather to update/skip/create new bootloader configuration.
I'll attach the report.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. After installing FC test2, restart the pc and run anaconda again to upgrade
your installation.
2. Click on next and choose to update the existing installation.
3. When you reach to the bootloader configuration, no matter what you choose,
you'll always get the error message and anaconda will terminate.

Actual Results:  Installation will always fail.

Expected Results:  Just to upgrade and/or install the missing packages or change

Additional info:

I'm sure of the ISO MD5SUMs and did a check on the first CD and it passed.
Comment 1 Ossama Khayat 2003-10-06 05:40:30 EDT
Created attachment 94944 [details]
Anaconda crash report

The report generated by the installer.
Comment 2 Jeremy Katz 2003-10-09 13:11:52 EDT
Can you provide the output of 'rpm -qa --qf
"%{EPOCH}:%{NAME}-%{VERSION}-%{RELEASE}\n"` on your system?
Comment 3 Ossama Khayat 2003-10-11 13:18:42 EDT
Well, I've removed the installation!! Anyway, I'll install the beasic packages
again and tried to upgrade and get you the info you need.
Comment 4 Ossama Khayat 2003-10-11 14:04:36 EDT
Created attachment 95118 [details]
Requested output from: rpm -qa --qf "%{EPOCH}:%{NAME}-%{VERSION}-%{RELEASE}\n"

BTW, the last time I tried the upgrade, I had different packages. This time I
installed it as Personal Desktop. I tried the upgrade again, but the bug still
Comment 5 Jeremy Katz 2003-10-13 18:25:52 EDT
Sorry, I need the output of that command from before the upgrade -- somehow
you've got a redhat-release package which has an unexpected epoch and haven't
seen that in any of our upgrading here.  

What were you upgrading from?
Comment 6 Ossama Khayat 2003-10-14 09:32:48 EDT
I added comments to the last attachement I did that I installed FC2 first as
Workstation installation, then I tried to upgrade again, since it found it and
offered the upgrade.
Basically, I was trying to install all the packages, since the Add/Remove
Software didn't work!
Comment 7 Jeremy Katz 2003-10-14 11:18:58 EDT
Fixed in CVS, update disk at http://people.redhat.com/~katzj/severn-t3-updates.img
Comment 8 Jeremy Katz 2003-10-14 11:20:25 EDT
And I'm actually building with the change now.

*** This bug has been marked as a duplicate of 98325 ***
Comment 9 Bill Nottingham 2003-10-17 09:58:03 EDT
*** Bug 107354 has been marked as a duplicate of this bug. ***
Comment 10 Ossama Khayat 2003-10-23 09:33:42 EDT
I've just tested FC-Test3 and tried to update. It fails again when I reach 
the 'Reading packages' status.
I'm trying to upgrade from FC-Test2 to Test3.
I'll attache the output again.
Comment 11 Ossama Khayat 2003-10-23 09:35:19 EDT
Created attachment 95430 [details]
the error while trying to upgrade from test2 to test3
Comment 12 Jeremy Katz 2003-10-23 10:29:29 EDT
The fix went in after test3.  

Note You need to log in before you can comment on or make changes to this bug.