This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 98325 - grub should require /usr/bin/cmp (or diffutils).
grub should require /usr/bin/cmp (or diffutils).
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: grub (Show other bugs)
1.0
All Linux
medium Severity low
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
: 107007 (view as bug list)
Depends On:
Blocks: CambridgeBlocker
  Show dependency treegraph
 
Reported: 2003-07-01 00:09 EDT by Aleksey Nogin
Modified: 2007-04-18 12:55 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-22 12:48:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Aleksey Nogin 2003-07-01 00:09:53 EDT
The /sbin/grub-install script will not work correctly if the cmp utility (from
the diffutils) package is missing. It might be a good idea to add an appropriate
"Requires" to the spec.
Comment 1 Jeremy Katz 2003-07-02 12:55:44 EDT
Added in CVS, will be in next build.
Comment 2 Jeremy Katz 2003-10-14 11:20:31 EDT
*** Bug 106343 has been marked as a duplicate of this bug. ***
Comment 3 Jeremy Katz 2003-10-14 17:50:17 EDT
*** Bug 107007 has been marked as a duplicate of this bug. ***
Comment 4 Miloslav Trmac 2003-10-18 09:51:45 EDT
Looks fixed now.
Comment 5 Dave Habben 2003-10-22 10:38:54 EDT
$ rpm -q grub
grub-0.93-7

$ rpm -q grub --requires | grep cmp
/usr/bin/cmp

Verified as fixed, this should be marked as RAWHIDE/CLOSED

Note You need to log in before you can comment on or make changes to this bug.