Bug 10662 - X crashes on reboot/halt
X crashes on reboot/halt
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: kdebase (Show other bugs)
6.2
All Linux
medium Severity high
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-04-08 12:55 EDT by Stelian Pop
Modified: 2008-05-01 11:37 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-07-21 10:30:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stelian Pop 2000-04-08 12:55:48 EDT
I'm not sure this bug is related to initscripts or X or kdm...

I upgraded (from 6.1) to RedHat 6.2 and I have a strange problem: each
time I select "halt" or "reboot" from the kdm login screen, kdm ends
and _restarts_ (instead of ending normally, and return to the text
console listing the shutdown items). But in the background, the system
initiates its shutdown sequence. After a while, at some time during the
shutdown sequence (I guess it's the xfs shutdown), the X server crashed and
presents a text screen full of debug details and registers.

The computer shutdown process seems to be unaffected, as it ends by
halting or rebooting the computer. But it's at least ugly...

Stelian.
Comment 1 Anonymous 2000-04-08 14:51:59 EDT
I have the same problem with KDM.  However, if I use GDM instead of KDM,
everything would go fine.
Comment 2 Anonymous 2000-04-13 16:15:59 EDT
I have installed the downloadable 6.2 version (iso) in three different machines,
2 from scratch and one upgrade and I have the same problem
Comment 3 Bill Nottingham 2000-04-18 15:47:59 EDT
That would be a kdm bug. Seems fixed as of the rawhide kdebase packages.
Comment 4 Stelian Pop 2000-04-21 03:43:59 EDT
How am I supposed to upgrade to the rawhide kdebase package? This
package has dependencies on many rawhide packages, and I intend to
use a stable redhat version, not the potentially unstable rawhide one.

Since this is a severe bug, a kdebase errata seems to be much more
appropriate to me...

Stelian.
Comment 5 leo 2000-05-10 08:52:59 EDT
I have a similar problem.
In addition to server crashes on shutdown, sometimes the shutdown procedure
fails on my system and it switches to runlevel 3.

I've done a strace on kdm (prefdm): strace -f -ff -F -o kdm.trace -p 4438
http://leo.wu-wien.ac.at/kdmtrace/

It looks like kdm calls halt (or "shutdown -r now" as I've specified in kdmrc)
and shutdown execs /sbin/init 0, so everything should be fine. I have no idea
why init switches back to runlevel 3...
Comment 6 Aleksey Nogin 2000-06-02 18:40:52 EDT
See also bug #11028 and bug #11598
Comment 7 S. Backhausen 2000-06-26 14:35:19 EDT
Hi there!

I played around with the rawhide-packages and didn4t get a solution for this 
prob, so I took a closer look at it. 

In the last line of /etc/inittab is an entry for the displaymanager 
(x:5:respawn:/etc/X11/prefdm -nodaemon). This entry tells init to restart the 
displaymanager each time it dies. When you shutdown your system, kdm is 
restarted when it dies until the next runlevel is reached (init only restarts 
kdm while the system is in runlevel 5).

My solution is to replace that line with:
x:5:once:/etc/X11/prefdm

This tells init to start the displaymanager only once in that runlevel. Init 
won4t restart it anymore when it dies. But that doesn4t matter, since kdm will 
now run in daemon mode and restart its child when it is dying. 

Hope this helps.

Sven
Comment 8 scheck 2000-07-12 06:01:01 EDT
Thank you for your inittab-workaround. 

The problems are gone!

But questions remains:

Why doesn't everybody have this problem? 
And why are there different behaviours like 
- normal shutdown
- X crash
- switch to runlevel 3
- runlevel 3 login-prompt freezed?

I'd like to understand the problem in detail.
Comment 9 John Sohn 2000-07-21 10:30:53 EDT
Thanks backhaussv@seeg.sharp-eu.com, your solution seemed to fixed the problem for me. 

I had this problem with KDM in RedHat 6.2. This problem did not occur for me in RedHat 6.1. I have installed RedHat 6.2 on two different PC's and only 
one of them has the problem. Since the problem is apparently random I was wondering if it was X and/or hardware related? The PC without the problem is 
an old Pentium 133 with an S3 Trio video card. The PC with the problem is a Celeron 300 with Nvidia TNT(1) video card.
Comment 10 Ngo Than 2000-09-09 08:45:29 EDT
fixed in Red Hat 7.0
Comment 11 Rex Dieter 2001-05-09 11:13:03 EDT
This problem isn't completely gone as of Redhat 7.1.  See my comment on Bug 
#11323

Note You need to log in before you can comment on or make changes to this bug.