Bug 11598 - kdm IO Error when shutdown option selected
kdm IO Error when shutdown option selected
Status: CLOSED DUPLICATE of bug 11323
Product: Red Hat Linux
Classification: Retired
Component: kdebase (Show other bugs)
6.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-05-23 06:13 EDT by ronnie
Modified: 2008-05-01 11:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-06-02 18:40:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description ronnie 2000-05-23 06:13:33 EDT
If on the kdm login screen the shutdown option
is chosen and either shutdown or shutdown and restart is
selected the screen then flickers between a grey screen
and the login window three times before returning to
the login window which then stays on the screen
until the machine either shuts down or reboots.
No messages about the daemons shutting down appear,
just the kdm login window. Further if the user then
selects shutdown again while the login window
remains present an X error occurs.

In /var/log/messages the following lines appear
on the shutdown options being selected:-

kdm[769]: IO Error in XOpenDisplay
kdm[754]: Display :0 cannot be opened

If I select /sbin/reboot or /sbin/halt while
in a kde session or remote logged in while
kdm is running, the above error does not occur.

In 6.1 this functions correctly.
Comment 1 Aleksey Nogin 2000-06-02 18:40:08 EDT
I only tried using kdm's "Shutdown" in RH6.2 once and I had the same problem.

Also, this is probably a duplicate of bug #10662 and bug #11028
Comment 2 Bernhard Rosenkraenzer 2000-10-20 08:26:33 EDT

*** This bug has been marked as a duplicate of 11323 ***
Comment 3 Rex Dieter 2001-05-10 10:42:35 EDT
See my comments on Bug #11323 on what I think causes this and a suggested 
work-around.

Note You need to log in before you can comment on or make changes to this bug.