Bug 11323 - X restarting on shutdown
X restarting on shutdown
Product: Red Hat Linux
Classification: Retired
Component: kdebase (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
: 11598 18523 (view as bug list)
Depends On:
  Show dependency treegraph
Reported: 2000-05-09 03:20 EDT by alan.hughes4
Modified: 2008-05-01 11:37 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2001-06-05 09:14:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description alan.hughes4 2000-05-09 03:20:19 EDT
When selecting "shutdown" or "shutdown and restart" on KDM, X dies as
expected, but then restarts (KDM also reappears). It subsequently dies a
second time complaining of a SIG 11 (I think) and reporting that it has
generated a core dump.

This might be a problem with KDM.

I have not tried it under GDM.
Comment 1 Craig Franklin 2000-05-13 22:21:59 EDT
I have had the same problem.  I had no luck fixing it.  I also tried many
different types installs (custom gui, custom text, kde workstation gui,...).
They all behaved the same.
Comment 2 Preston Brown 2000-09-11 13:31:17 EDT
this is a kdm issue.
Comment 3 alan.hughes4 2000-10-18 10:09:40 EDT
This behaviour has now been reproduced on Redhat 7. Note however that the error 
messages generated by the X-server (now 4.0.1) are different.
Comment 4 Bernhard Rosenkraenzer 2000-10-20 08:22:37 EDT
The problem is that /etc/inittab runs [kgx]dm as :respawn: rather than :once:.
kdm dies, init restarts it before it's told to go to runlevel 3.
Comment 5 Bernhard Rosenkraenzer 2000-10-20 08:26:31 EDT
*** Bug 11598 has been marked as a duplicate of this bug. ***
Comment 6 Bernhard Rosenkraenzer 2000-10-20 10:14:18 EDT
*** Bug 18523 has been marked as a duplicate of this bug. ***
Comment 7 Need Real Name 2000-10-20 11:45:34 EDT
Per beros' comment above, editing the following line in /etc/innitab did the

original "x:5:respawn:/etc/X11/prefdm -nodaemon"
change to "x:5:once:/etc/X11/prefdm -nodaemon"

smooth shutdown/reboot now.
Comment 8 Bill Nottingham 2001-01-29 19:52:30 EST
Except, you don't want this behavior; you want it to respawn if it dies.
Comment 9 Rex Dieter 2001-05-09 11:08:11 EDT
This really is a kdebase/kdm bug.  Let me explain what I've found in the past 
few days:

I can verify that this problem exists on RedHat 7.1 (and RedHat 6.2 with 
kde-2.1.1 installed).  The specific problem is about the same as the original 
poster: Upon selecting Shutdown from kdm, the shutdown sequence is not 
displayed on the screen, and in the case of RedHat 6.2, the X/kdm restarts, 
only to die soon afterward with kdm restarts itself.

This problem has existed going all the way back to kde-1.1.2 on RedHat 6.2, 
and I've never been able to fix it, other than editing /etc/inittab to have:
but this is not optimal, and breaks other things (like logging in remotely via 

I have finally tracked the source of this down to a patch in kdebase:  
I'm not sure what this patch is supposed to do, but in the case of 
kdm-spawned-from-inittab, it does that wrong thing.  It results in a kdm that 
restarts itself upon clicking Shutdown.  I've rebuilt kdebase-2.1.1-8 without 
that patch applied, and kdm now functions as expected... showing the shutdown 
sequence to the screen.

Comment 10 Rex Dieter 2001-05-21 16:29:12 EDT
Can this bug please be reopened?  It is not resolved and it needs to be fixed. 

To verify the problem is still there, try this:  from the kdm login window,
click Shutdown to Console.  ( It won't work.  kdm will restart itself.).
Comment 11 Jeff Jirsa 2001-06-04 23:34:42 EDT
So, is this also affect shutting down?  When I shutdown from KDM, it looks like 
KDM exits with an error/warning message and the system hard reboots.  It is not 
calling shutdown - I don't see any of thethe regular shutdown messages.  When 
the system reboots, it had to run fsck on the file systems.  This is BAD news, 
Comment 12 Rex Dieter 2001-06-05 09:14:28 EDT
Yes, this affects shutdown's too, and will lead to the symptoms you describe:
not seeing shutdown messages, and many times an fsck.

You're welcome to try my fixed rpm package (without redhat's wait-kdm patch that
fixed the problem for me) from my website:
Comment 13 Bernhard Rosenkraenzer 2001-07-17 07:16:11 EDT
Fixed in 2.1.1-13

Note You need to log in before you can comment on or make changes to this bug.