Bug 106673 - start menu icon fuzzy
start menu icon fuzzy
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gnome-panel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mark McLoughlin
: Triaged
: 106521 (view as bug list)
Depends On:
Blocks: CambridgeBlocker
  Show dependency treegraph
 
Reported: 2003-10-09 09:58 EDT by Alexander Larsson
Modified: 2007-11-30 17:10 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-27 02:26:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexander Larsson 2003-10-09 09:58:35 EDT
The red hat icon on the panel looks like a small icon scaled up.
Comment 1 Alexander Larsson 2003-10-09 10:32:36 EDT
This happens to drawer icons too. It seems the panel handles icon themes in a
quite busted way. It gets a 24x24 (PANEL_DEFAULT_MENU_ICON_SIZE) icon from the
icon theme, then registers that with the gtk stock system (in only that size).
Then buttons render with:
 button->pixbuf = gtk_widget_render_icon (
					GTK_WIDGET (button),
					button->stock_id,
					(GtkIconSize) -1,
					NULL);
which is then scaled to the right size.

Since we now have 24x24 icons as well as 48x48 ones we get the 24x24 icons
scaled to 48x48 in size 48 panels.

Comment 2 Bill Nottingham 2003-10-09 14:29:45 EDT
This is reported in a couple other places, might want to find them and dup them
here.
Comment 3 Bill Nottingham 2003-10-09 14:31:23 EDT
*** Bug 106521 has been marked as a duplicate of this bug. ***
Comment 4 Bill Nottingham 2003-10-21 15:56:05 EDT
I think this is fixed in current panels, please confirm.
Comment 5 Kai Thomsen 2003-10-21 16:30:40 EDT
Fedora icon looks o.k., but drawer icon and most action icons (see bug 106521) 
are fuzzy. Tested with a fresh user account on FC test3 updated via Rawhide.
Comment 6 Owen Taylor 2003-10-21 16:49:46 EDT
The red hat was a gnome-panel bug fixed in gnome-panel-2.4.0-2

The other icons are problems with the Bluecurve icon theme ... right
now it's providing all themed icons at only 24 pixels.
Comment 7 Leonard den Ottolander 2004-02-26 08:13:57 EST
Can be closed CURRENTRELEASE as it is no issue with FC1 anymore.

Note You need to log in before you can comment on or make changes to this bug.