Bug 106826 - evolution-wombat does not exit politely at end of session
Summary: evolution-wombat does not exit politely at end of session
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: evolution   
(Show other bugs)
Version: rawhide
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Keywords:
: 107580 (view as bug list)
Depends On:
Blocks: CambridgeBlocker
TreeView+ depends on / blocked
 
Reported: 2003-10-11 00:49 UTC by Paul W. Frields
Modified: 2007-11-30 22:10 UTC (History)
5 users (show)

Fixed In Version: 1.4.5-7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-29 22:20:23 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot of gnome-settings-daemon errors. (36.18 KB, image/jpeg)
2003-10-11 00:55 UTC, Paul W. Frields
no flags Details
implement session management for wombat (5.74 KB, patch)
2003-10-23 19:21 UTC, Jeremy Katz
no flags Details | Diff

Description Paul W. Frields 2003-10-11 00:49:43 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1) Gecko/20031009

Description of problem:
The evolution-wombat process appears to be related to (if not responsible for)
several of the problems users have observed with the gnome-settings-daemon
dropping applets after gdm login, as well as various hangs in evolution with
some less updated systems. evolution-wombat appears to hang after logging out of
GNOME. This has been observed by a number of members on fedora-test-list.

I have found that after logging out of GNOME, switching to a text tty and
killing the evolution-wombat process releases the bonobo-activation-server and
restores GNOME to proper functioning at the next login. I'm not sure how to
proceed further with this bug report other than to give some appropriate version
numbers. The system is an Athlon Tbird-1.4GHz, FC-0.94 and
kernel-2.4.22-1.2088.nptl with all updates as of this writing (i.e., practically
0.95 at this point).

Other possibly related packages (?):
libbonobo-2.4.0-1
gdm-2.4.4.3-5
control-center-2.4.0-1
gnome-panel-2.4.0-3

More information available upon request....

Version-Release number of selected component (if applicable):
evolution-1.4.5-2

How reproducible:
Always

Steps to Reproduce:
1. Run evolution, then exit.
2. Log out of GNOME.
3. Log back in.
4. Gnome-settings-daemon produces numerous errors, including failure to load any
user-setup applets in panel.
5. Repeat 1-3 as often as desired to repeatedly view problem.
6. Log out of GNOME.
7. Switch to text virtual terminal and kill evolution-wombat process. Note that
bonobo-activation-server also quits at that time as well.
8. Switch back to X server and login to GNOME, at which time problem does not
recur. 

Additional info:
A screenshot will be inserted in the next comment showing both the initial error
(at the upper left) and then the errors per applet (at the lower right).

Comment 1 Paul W. Frields 2003-10-11 00:55:20 UTC
Created attachment 95113 [details]
Screenshot of gnome-settings-daemon errors.

Comment 2 Tim Waugh 2003-10-13 08:51:42 UTC
Just killing the bonobo process works around this; nothing to do with wombat
then I guess.

Comment 3 Paul W. Frields 2003-10-14 13:21:50 UTC
Apparently I don't understand the wombat/bonobo relation well, for which I
apologize. When I log out of GNOME, if I switch to a tty and login there, I
still see both the evolution-wombat and bonobo-activation-server processes
alive. Killing wombat also ends the bonobo-a-s process, but killing b-a-s does
not end the wombat process. Therefore I came to the tentative conclusion that
the proper behavior was probably for wombat to be terminating in some courteous
fashion during the logout process, allowing b-a-s to finish as well.

Comment 4 Tim Waugh 2003-10-14 13:42:26 UTC
I don't understand it myself.  I think you are probably right.

Comment 5 Thomas J. Baker 2003-10-15 20:07:24 UTC
I experience this after every logout/login. Just killing b-a-s fixes things.

Comment 6 Paul W. Frields 2003-10-18 01:05:10 UTC
Same bad behavior in kernel-2.4.22-1.2096.nptl. Once again, the problem is not
in the bonobo-activation-server. The wombat process does not end properly, which
apparently means that bonobo-activation-server can't either. I can only hope
Havoc understands this stuff. :-) I'm assuming from the relative silence that
there's nothing else I can do to help track this down.

Comment 7 Paul W. Frields 2003-10-18 15:47:22 UTC
For additional information at GNOME's Bugzilla:

http://bugzilla.gnome.org/show_bug.cgi?id=124707

Also, I have changed title to reflect reality. Should this be moved to UPSTREAM?

Comment 8 Michael K. Johnson 2003-10-21 19:45:57 UTC
*** Bug 107580 has been marked as a duplicate of this bug. ***

Comment 9 Jeremy Katz 2003-10-23 19:21:30 UTC
Created attachment 95444 [details]
implement session management for wombat

Attached patch implements session management for evolution-wombat.  Sent
upstream for comments.

Comment 10 Jeremy Katz 2003-10-27 22:48:09 UTC
Added patch to evolution to fix this for FC1.  Patch has been rejected
by upstream, though as it adds a dependency on the DISPLAY for
evolution-wombat.

Comment 11 Paul W. Frields 2003-10-29 22:20:23 UTC
Tested 1.4.5-7, appears to work just fine now. Thanks Jeremy.

Comment 12 Rex Dieter 2003-10-31 22:33:54 UTC
FYI, rebuilt evolution-1.4.5-7 on rh9 *still* has the problem.

-- Rex 

Comment 13 Rex Dieter 2003-10-31 22:39:55 UTC
This is what gnome's bugzilla claims to fix it (in libbonobo):

diff -u -p -u -r1.41 bonobo-activation-activate.c
--- bonobo-activation/bonobo-activation-activate.c      9 Jun 2003
13:17:55 -0000       1.41
+++ bonobo-activation/bonobo-activation-activate.c      29 Oct 2003
13:23:01 -0000
@@ -714,6 +714,7 @@ bonobo_activation_init_activation_env (v
                { "SESSION_MANAGER", NULL }, /* XSMP session manager */
                { "AUDIODEV",        NULL }, /* Audio device on Sun
systems */
                { "LANG",            NULL }, /* Fallback locale name */
+                { "XAUTHORITY",      NULL },
                { NULL,              NULL }
        };

I applied this patch to rh9's bonobo-activation, but it didn't seem to
help any.  )-:

Comment 14 Rex Dieter 2003-11-02 08:05:45 UTC
FYI, for the problem to go away on rh9, I had to upgrade other items
as well: libbonobo-2.4.0 (patched as above), libbonoboui-2.4.0,
GConf2-2.4.0, ORBit2-2.8.2 (and linc 1.0.3).

Comment 15 Rex Dieter 2003-11-06 20:18:17 UTC
Not the end of the story, turns on the wombat patch made the Calendar
non-functional.  Rebuilding without it fixed the Calendar, and it
turns out I'm not seeing the original problem either (perhaps it
really was fixed solely by the bonobo-action/XAUTHORITY patch).

OK, I'm really done this time.  (-;

Comment 16 Paul W. Frields 2003-11-13 20:02:20 UTC
To follow up on Rex's comments, and add some new experience, the
problem is recurring in FC1. The wombat process now stops politely,
but bonobo-activation-server persists, causing the same problem. Havoc
or Tim... should this bug be reopened at this point? Apparently other
people are still seeing this as well, cf. #109449 for example.

Comment 17 Mark Levitt 2004-04-22 05:21:21 UTC
Yes, I'm seeing this problem on FC1. 

I have NFS mounted home directories.


Note You need to log in before you can comment on or make changes to this bug.