Bug 106884 - Cannot change display settings in GUI
Cannot change display settings in GUI
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: redhat-config-xfree86 (Show other bugs)
1.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
David Lawrence
:
: 99545 108043 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-12 22:25 EDT by Jim Cornette
Modified: 2007-04-18 12:58 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-15 20:30:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
These were .xsession errors (8.76 KB, text/plain)
2003-10-12 22:30 EDT, Jim Cornette
no flags Details
Latest XFree86.0log (30.32 KB, text/plain)
2003-10-12 22:32 EDT, Jim Cornette
no flags Details
after config-xfree86 XFreelog (30.35 KB, text/plain)
2003-10-14 23:19 EDT, Jim Cornette
no flags Details
Adding my current XF86Config file (last edited aug 13, 2003) (3.13 KB, text/plain)
2003-10-14 23:29 EDT, Jim Cornette
no flags Details

  None (edit)
Description Jim Cornette 2003-10-12 22:25:16 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1) Gecko/20031009

Description of problem:
When inside the GNOME window manager and running redhat-config-xfree86, I get
asked for a root password, then nothing is displayed, except the icon to keep
root priveledges.

If I open up a gnome-terminal, as root, I get the following message.

 /usr/bin/redhat-config-xfree86
* ddcprobe returned bogus values:
ID:   HSD1508
Name: �FZP�
HorizSync: None
VertSync:  None
 
Traceback (most recent call last):
  File "/usr/share/redhat-config-xfree86/xconf.py", line 406, in ?
    dialog = xConfigDialog.XConfigDialog(hardware_state, xconfig, vc)
  File "/usr/share/redhat-config-xfree86/xConfigDialog.py", line 327, in __init__
    self.setup_ui_resolution(self.state.get_resolution())
  File "/usr/share/redhat-config-xfree86/xConfigDialog.py", line 50, in
setup_ui_resolution
    self.res_option_menu.set_history(current)
UnboundLocalError: local variable 'current' referenced before assignment


Version-Release number of selected component (if applicable):
redhat-config-xfree86-0.9.9-2 and XFree86-4.3.0-39 and kernel-2.4.22-1.2088.nptl

How reproducible:
Always

Steps to Reproduce:
1. Upgrade to latest XFree86 version
2. go to system settings
3.select display
    

Actual Results:  When display chosen from menu, nothing happened, except root
password asked for and ICON for keeping athority in lower right panel. No GUI
program or error message displayed.

Expected Results:  I expected a display resolution screen to be presented.

Additional info:

This choice was to aid in testing the latest versions of XFree86. Since I was
testing the program. I tried to see which resolutions were available
Comment 1 Jim Cornette 2003-10-12 22:30:02 EDT
Created attachment 95125 [details]
These were .xsession errors
Comment 2 Jim Cornette 2003-10-12 22:32:31 EDT
Created attachment 95126 [details]
Latest XFree86.0log

This is for if information from this file is needed.
Comment 3 Brent Fox 2003-10-13 18:54:42 EDT
Ah, I see. 'current' wasn't being initialized unless the list of available
resolutions could be retrieved.  Since ddcprobe was returning bogus values, the
list was unavailable, so 'current' wasn't initialized.  Should be fixed in
redhat-config-xfree86-0.9.10-1.  Thanks for your report.
Comment 4 Jim Cornette 2003-10-13 20:39:44 EDT
I'm glad it bis resolved now, with the next version. Looking forward to having
it working again.
Comment 5 Deji 2003-10-14 16:39:00 EDT
Hi,
I,m a newbie here and i'm not sure if its right to add this here (since the bug
had already been declared closed).
I've updated to the latest redhat-config-xfree86 (-0.9.10-1), and using
XFree86-4.3.0-39, i still have the said problem of starting display setting. The
message i got is
[root@rhema deji]# redhat-config-xfree86
* ddcprobe returned bogus values:
ID:   SEC0000
Name: None
HorizSync: None
VertSync:  None
 
Traceback (most recent call last):
  File "/usr/share/redhat-config-xfree86/xconf.py", line 406, in ?
    dialog = xConfigDialog.XConfigDialog(hardware_state, xconfig, vc)
  File "/usr/share/redhat-config-xfree86/xConfigDialog.py", line 398, in __init__
    key, value = string.split(card.driver, ":")
ValueError: unpack list of wrong size.

I have a laptop with radeon IGP 340M (345M?). The card was not detected during a
clean install of FC test3, ditto for both test1 and 2 but i've then been able to
use the display setting to change the vesa driver to radeon mobility U1.
Regards.
Comment 6 Jim Cornette 2003-10-14 23:13:06 EDT
I installed redhat-config-xfree86-0.9.10-1 and then tried to change the display.
I got additional errors, as described below.

I will attach XFree86.0.log and .xsession errors again.




[root@jcsevern jim]# redhat-config-xfree86
* ddcprobe returned bogus values:
ID:   HSD1508
Name: �FZP�
HorizSync: None
VertSync:  None
 
Traceback (most recent call last):
  File "/usr/share/redhat-config-xfree86/xconf.py", line 406, in ?
    dialog = xConfigDialog.XConfigDialog(hardware_state, xconfig, vc)
  File "/usr/share/redhat-config-xfree86/xConfigDialog.py", line 380, in __init__
    self.secondResolutionOptionMenu.set_history(current)
UnboundLocalError: local variable 'current' referenced before assignment
Comment 7 Jim Cornette 2003-10-14 23:19:01 EDT
Created attachment 95183 [details]
after config-xfree86 XFreelog
Comment 8 Jim Cornette 2003-10-14 23:29:45 EDT
Created attachment 95184 [details]
Adding my current XF86Config file (last edited aug 13, 2003)
Comment 9 Brent Fox 2003-10-15 20:30:48 EDT
Oops, I made the change in the wrong part of the code.  Give
redhat-config-xfree86-0.9.12-1 a try and see if that doesn't work.
Comment 10 Deji 2003-10-16 18:42:48 EDT
redhat-config-xfree86-0.9.12-1 too doesn't seems to have the problem, i still
get this,
[root@rhema deji]# redhat-config-xfree86
* ddcprobe returned bogus values:
ID:   SEC0000
Name: None
HorizSync: None
VertSync:  None
 
Traceback (most recent call last):
  File "/usr/share/redhat-config-xfree86/xconf.py", line 406, in ?
    dialog = xConfigDialog.XConfigDialog(hardware_state, xconfig, vc)
  File "/usr/share/redhat-config-xfree86/xConfigDialog.py", line 399, in __init__
    key, value = string.split(card.driver, ":")
ValueError: unpack list of wrong size.
Comment 11 Jim Cornette 2003-10-16 19:06:49 EDT
The fix worked. But there were a few things that I did before trying the newer
version.

I did get a message on screen. This message was printed on screen.

* ddcprobe returned bogus values:
ID:   HSD1508
Name: �FZP�
HorizSync: None
VertSync:  None


Back to the steps I did to get redhat-config to work. 
1) go to ftp://people.redhat.com/bfox and retrieve the version from the site.
2) run rpm -U redhat-config*.rpm --oldpackage
3) run redhat-config-xfree86. It brings up the program. Change a few settings,
then restart X.
4) notice that I could only check 640 x 480 resolution.
5) Install the version of redhat-config-xfree86 from severn2
6) Change display settings to reflect an hp LCD 14 inch display. Previously
there was no selection for display.
7) Exit X, then restart.
8) run redhat-config-xfree86 and select display. Select 1280 x 690. 
9) close, then restart X. Notice display is a lot better.
10) install redhat-config-xfree86-0.9.12-1
11) run redhat-config-xfree86-0.9.12-1
12) Check display settings, but did not try to change them.

As a note: During the initial installation of Severn. I could not choose the
display during the install. I just passed it. This problem followed through from
 all beta cycles 1,2 and 3

I assume that this shortcoming might be causing some X configuration problems.

Jim
Comment 12 Brent Fox 2003-10-22 14:09:35 EDT
*** Bug 99545 has been marked as a duplicate of this bug. ***
Comment 13 Brent Fox 2003-10-28 14:41:38 EST
*** Bug 108043 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.