Bug 108043 - redhat-config-xfree86 fails to run
Summary: redhat-config-xfree86 fails to run
Status: CLOSED DUPLICATE of bug 106884
Alias: None
Product: Fedora
Classification: Fedora
Component: redhat-config-xfree86 (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Brent Fox
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: CambridgeBlocker
TreeView+ depends on / blocked
 
Reported: 2003-10-26 23:11 UTC by Eric N. Ebert
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 18:59:26 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Eric N. Ebert 2003-10-26 23:11:59 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.1; Linux)

Description of problem:
When attempting to run redhat-config-xfree86 I get the following error message:

[root@Xwing redhat-config-xfree86]# ./redhat-config-xfree86
Traceback (most recent call last):
  File "/usr/share/redhat-config-xfree86/xconf.py", line 406, in ?
    dialog = xConfigDialog.XConfigDialog(hardware_state, xconfig, vc)
  File "/usr/share/redhat-config-xfree86/xConfigDialog.py", line 327, in __init__
    self.setup_ui_resolution(self.state.get_resolution())
  File "/usr/share/redhat-config-xfree86/xConfigDialog.py", line 50, in setup_ui_resolution
    self.res_option_menu.set_history(current)
UnboundLocalError: local variable 'current' referenced before assignment

I am running an old TNT RIVA video card and a NEC MultiSync FE700 monitor. I've run this against the 2.4 kernel that came with Fedora and 2.6.0-test9. It fails the same way every time. I recently upgraded to Fedora-test3 from RH 8.0.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Run /usr/share/redhat-config-xfree86/redhat-config-xfree86
2.
3.
    

Actual Results:  The Error message described above

Expected Results:  Start the X Configurator

Additional info:

Comment 1 Felix Miata 2003-10-27 12:54:27 UTC
Exact same thing happens to me with ET6100 graphics card and unlisted, non-DDC,
1280x1024 monitor on fresh test3 install.

Comment 2 Felix Miata 2003-10-27 12:56:46 UTC
Forgot to add that prior to the reporter's messages, I also see the following:

* ddcprobe returned bogus values:
ID

Comment 3 Felix Miata 2003-10-27 12:58:20 UTC
Forgot to add that prior to the reporter's messages, I also see the following:

* ddcprobe returned bogus values:
ID: IBM0846
Name: None
HorizSync: None
VertSync: None

Comment 4 Brent Fox 2003-10-28 19:41:34 UTC

*** This bug has been marked as a duplicate of 106884 ***

Comment 5 Red Hat Bugzilla 2006-02-21 18:59:26 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.