Bug 1069628 - It's possible to set nonsense value of RAM size of vm/template.
Summary: It's possible to set nonsense value of RAM size of vm/template.
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-engine-core
Version: 3.4
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 3.4.1
Assignee: Martin Betak
QA Contact: Pavel Stehlik
URL:
Whiteboard: virt
: 1073450 1076094 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-25 12:27 UTC by Ondra Machacek
Modified: 2014-05-08 13:37 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-05-08 13:37:10 UTC
oVirt Team: ---


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 1014952 0 unspecified CLOSED [admin portal] cannot add Windows VM with 512MB memory, or more than 64GB 2021-02-22 00:41:40 UTC
oVirt gerrit 26268 0 None MERGED frontend: Proper VM SystemTab Validation Never
oVirt gerrit 26387 0 None MERGED frontend: Proper VM SystemTab Validation Never

Internal Links: 1014952

Description Ondra Machacek 2014-02-25 12:27:37 UTC
Description of problem:
When creating/updating vm, it's possible to set nonsense value of RAM of vm.
There is tooltip for setting mimunum ram size of 256MB and it is possible to 
set value < 256M and if it's bigger then some limit(ie 2147483647 GB) then it 
overflows to zero. 

It's also possible to write value like: '12a30 MB'. Which 
is truncated to 12. Would be better to tell there is nonsense value.

Since ovirt supports up to 2TB RAM of vm, would be good to also allow input in
* TB. Which is not working now( TB is considered as MB ).

Version-Release number of selected component (if applicable):
ovirt-engine-3.4.0-0.11.beta3.el6.noarch

How reproducible:
always

Steps to Reproduce:
1. Check description of problem.

Actual results:


Expected results:


Additional info:

Comment 1 Ondra Machacek 2014-02-25 12:49:55 UTC
Please also fix the REST for long values. (see bug 1000796).

Comment 2 Itamar Heim 2014-03-02 05:42:53 UTC
Setting target release to current version for consideration and review. please
do not push non-RFE bugs to an undefined target release to make sure bugs are
reviewed for relevancy, fix, closure, etc.

Comment 3 Sandro Bonazzola 2014-03-04 09:27:48 UTC
This is an automated message.
Re-targeting all non-blocker bugs still open on 3.4.0 to 3.4.1.

Comment 4 Michal Skrivanek 2014-03-09 13:14:08 UTC
*** Bug 1073450 has been marked as a duplicate of this bug. ***

Comment 5 Omer Frenkel 2014-03-09 13:39:03 UTC
please note it was requested in bug 1014952 not to block the user from setting not recommended values (like <256) so there should be a warning in the event log for this.
anyway we do need some sanity, memory should be a number, non negative and shouldn't exceed max int.

Comment 6 Omer Frenkel 2014-03-16 09:11:34 UTC
*** Bug 1076094 has been marked as a duplicate of this bug. ***

Comment 7 Sandro Bonazzola 2014-05-08 13:37:10 UTC
This is an automated message

oVirt 3.4.1 has been released:
 * should fix your issue
 * should be available at your local mirror within two days.

If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.