Bug 107133 - anaconda crash at install after updating installation cd
Summary: anaconda crash at install after updating installation cd
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda   
(Show other bugs)
Version: 7.3
Hardware: i686
OS: Linux
medium
high
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-10-15 09:35 UTC by karen van der ploeg
Modified: 2007-04-18 16:58 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-24 18:48:01 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
crash dump txt generated by anaconda (49.85 KB, text/plain)
2003-10-15 09:36 UTC, karen van der ploeg
no flags Details
list of updated packages (2.51 KB, text/plain)
2003-10-15 09:42 UTC, karen van der ploeg
no flags Details

Description karen van der ploeg 2003-10-15 09:35:23 UTC
Description of problem:
When installing updated RedHat 7.3, anaconda crashed with bug report. 
I update the standard 7.3 release with the updates (kernel etc) and removed the 
old rpms. Regenerated a hdlist and created a bootable cd with boot.img. It 
boots OK, I get to go through the whole menu of selecting type of installation O
(workstation) and so on and after last page of startup menu, anaconda comes 
with crash dump. 
Key error in crash dump is man-pages-cs (last line of crash dump). Anaconda 
asks to report it in bugzilla. Will attach list of changed rpms. 


Version-Release number of selected component (if applicable):
n/a (standard 7.3 anaconda version) 

How reproducible:
All the time. 


Steps to Reproduce:
1.create bootable cd from updated rpms
2.boot from cd
3.follow menu

anaconda will crash after all installation preparation steps. NB: file systems 
are not formatted after crash. 
    
Actual results:
No installation or format has taken place. 

Expected results:
Installation of workstation RedHat 7.3

Additional info:
Have checked bugzilla for other reports on this issue, bugs 59476, 58516, 59769 
and 58827 are also about anaconda crashing but do not provide a solution for 
this issue.

Comment 1 karen van der ploeg 2003-10-15 09:36:50 UTC
Created attachment 95194 [details]
crash dump txt generated by anaconda

Comment 2 karen van der ploeg 2003-10-15 09:42:49 UTC
Created attachment 95196 [details]
list of updated packages

I copied all these rpms into the cd1/RedHat/RPMS and cd2/RedHat/RPMS
directories, removed the old versions of these rpms, regenerated a hdlist using
anaconda-runtime (genhdlist --withnumbers --hdlist ~/cd1/RedHat/base/hdlist
~/cd1 ~/cd2) 
and created a new bootable cd: 
mkisofs -V RedHat73_updated -b images/boot.img -c boot.cat -J -r -T -o cd1.iso
~/cd1
and mkisofs -V RedHat73_updated -J -r -T -o cd2.iso ~/cd2

and burnt this on cd: 
cdrecord -v speed=4 dev=0,0 -data cd1.iso 
and cd2.iso (I never got to try cd2 since anaconda already crashes at cd1).

Comment 3 Jeremy Katz 2003-10-24 18:48:01 UTC
Your comps file references a package which isn't present in your
hdlist, likely because you didn't include all 3 cds in your gendhlist
command.


Note You need to log in before you can comment on or make changes to this bug.